Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77858 - Bad pkgconfig path for XFree86-devel
Summary: Bad pkgconfig path for XFree86-devel
Keywords:
Status: CLOSED DUPLICATE of bug 77815
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-14 14:37 UTC by Nicolas Mailhot
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-15 01:57:52 UTC


Attachments (Terms of Use)

Description Nicolas Mailhot 2002-11-14 14:37:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.2b) Gecko/20021114

Description of problem:
XFree86-devel install its pkgconfig files in /usr/X11R6/lib/pkgconfig/, which is
not the default pkgconfig directory.

This confuses the system and hampers for example xft mozilla build, since it
needs xft.pc and does not find it in pkgconfig normal directory.

(and what's the point anyway of /usr/X11R6/lib/pkgconfig, it only contains two
files on my system)

So either pkgconfig should be fixed to also look in this dir or the pc files
should be installed in normal directory

(btw red mouse cursors are very outlandish ; is there a way to select gold ones
instead (or even in the relevant gnome2 dialog) ?)

Comment 1 Mike A. Harris 2002-11-15 01:57:45 UTC
The pkgconfig stuff is currently in the location that XFree86 installs
it when building.  This is a known issue, and will be fixed soon.



Comment 2 Mike A. Harris 2002-11-15 01:58:37 UTC

*** This bug has been marked as a duplicate of 77815 ***


Note You need to log in before you can comment on or make changes to this bug.