Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77857 - install of rpm is broken after upgrade
Summary: install of rpm is broken after upgrade
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-14 14:10 UTC by Rutger Noot
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-14 14:10:58 UTC


Attachments (Terms of Use)

Description Rutger Noot 2002-11-14 14:10:52 UTC
Description of Problem:

The install of the rpm package is broken after an upgrade from Red Hat 7.2
to 8.0


Version-Release number of selected component (if applicable):
rpm-4.1-1.06

How Reproducible:

Steps to Reproduce:
1. Upgrade from RH 7.2 to 8.0
2. type  rpm -V rpm
3. 

Actual Results:
inconsistencies  (L, symlink) are reported on 
/usr/lib/rpm/i[3456]86-linux  and
/usr/lib/rpm/noarch-linux
and on /usr/lib/rpm/i386-linux/macros  (size, MD5 sum)

Expected Results:
No message (no news=good news)

Additional Information:
I think the cause of the problem is this: 
under RH 7.2, there are symlink from 
/usr/lib/rpm/i?86-linux to /usr/lib/rpm/i?86-redhat-linux
AND FROM /usr/lib/rpm/noarch-linux to /usr/lib/rpm/i386-redhat-linux
rpm-4.1 expects directories, but the upgrade does not remove the 
symlinks, it just writes its files where it thinks they should go. 
So they end up in i?86-redhat-linux and (worst of all) the file
noarch-linux/macros overwrites the file from i386-linux/macros

To make this go away, I had to remove the symlinks by hand and 
rpm -Uvh --force rpm-4.1-1.06.i386.rpm

Comment 1 Jeff Johnson 2002-11-15 17:39:48 UTC
Yup.

Removing the symlinks before upgrading is the fix.
(the --force is necessary only if you did not do this)


Note You need to log in before you can comment on or make changes to this bug.