Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77853 - ppp daemon crashes ~30 seconds after connection is established
Summary: ppp daemon crashes ~30 seconds after connection is established
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp
Version: 7.2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-14 13:48 UTC by Need Real Name
Modified: 2015-01-08 00:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-16 16:13:31 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-14 13:48:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I am trying to set up a PPP for dial in from remote sites. The plan is to dial 
directly to a modem, with mgetty monitoring the port. The modem will pick up, 
user will login and as part of the user set up, a script will be run that will 
automatically start pppd. Right now the connection dies after about 30 seconds 
because the modem will hang up.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.dial in from remote laptop running Windows 98, using Hyperterminal.
2.Enter username and password at the prompt
3.pppd will start, then the connection will die after 30 seconds.
	

Actual Results:  Modem will pick up successfully, connection is established. 
pppd will start, but die out after 30 seconds. 

Expected Results:  Have the pppd connection stay up, and also have the PPP 
server assign the remote laptop an IP address for network access. 

Additional info:

I have the capture from the /var/log/messages:

Nov 13 09:02:01 localhost mgetty[1047]: data dev=ttyS0, pid=1047,
caller='none', conn='28800/ARQ/V34/LAPM/V42BIS', name='', cmd='/bin/login',
user='ppp'
Nov 13 09:02:05 localhost login(pam_unix)[1047]: session opened for user ppp
by LOGIN(uid=0)
Nov 13 09:02:05 localhost login -- ppp[1047]: DIALUP AT ttyS0 BY ppp
Nov 13 09:02:05 localhost login -- ppp[1047]: LOGIN ON ttyS0 BY ppp
Nov 13 09:02:06 localhost kernel: CSLIP: code copyright 1989 Regents of the
University of California
Nov 13 09:02:06 localhost kernel: PPP generic driver version 2.4.1
Nov 13 09:02:06 localhost pppd[1388]: pppd 2.4.1 started by ppp, uid 501
Nov 13 09:02:06 localhost pppd[1388]: Using interface ppp0
Nov 13 09:02:06 localhost pppd[1388]: Connect: ppp0 <--> /dev/ttyS0
Nov 13 09:02:36 localhost pppd[1388]: LCP: timeout sending Config-Requests
Nov 13 09:02:36 localhost pppd[1388]: Connection terminated.
Nov 13 09:02:36 localhost pppd[1388]: Exit.
Nov 13 09:02:36 localhost login(pam_unix)[1047]: session closed for user ppp

Comment 1 Thomas Woerner 2004-08-16 16:13:31 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.


Note You need to log in before you can comment on or make changes to this bug.