Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77851 - RPM allows multiple copies of kernel to be installed
Summary: RPM allows multiple copies of kernel to be installed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-14 13:00 UTC by Jeremy Sanders
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-15 11:11:09 UTC


Attachments (Terms of Use)

Description Jeremy Sanders 2002-11-14 13:00:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016

Description of problem:
rpm-4.0.4-7x.18 allows the errata kernel rpm kernel-2.4.18-17.7.x (athlon) to be
installed multiple times with -i. It is then impossible to remove the kernel rpm:

[root@xpc1 per]# rpm -e kernel-2.4.18-17.7.x
error: "kernel-2.4.18-17.7.x" specifies multiple packages


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -i kernel-2.4.18-17.7.x.athlon.rpm
2. rpm -i kernel-2.4.18-17.7.x.athlon.rpm
3. rpm -e kernel-2.4.18-17.7.x
	

Additional info:

[root@xpc1 per]# rpm -qa | grep kernel
kernel-2.4.18-17.7.x
kernel-2.4.18-17.7.x
kernel-2.4.18-11
kernel-2.4.18-14
kernel-2.4.18-17.7.x

Comment 1 Mike McLean 2002-11-14 21:45:42 UTC
try 'rpm -e --allmatches kernel-2.4.18-17.7.x' ... or some variation thereof

Comment 2 Jeremy Sanders 2002-11-15 11:00:27 UTC
Thanks - that command got rid of the kernel. Should rpm have allowed an install
of more than one of the same kernel?

I also ran into another rpm kernel problem, where rpm got stuck installing that
same kernel rpm, trying to unmount a temporary loopback initrd image (the umount
process was stuck at 100% cpu and couldn't be killed, even with kill -9). I
can't reproduce it (but I saw it on two machines), so I haven't filed another bug.


Comment 3 Jeremy Sanders 2002-11-15 11:11:02 UTC
As regards the second comment, the stack trace of the stuck umount and the loop
device are:

Nov 15 11:08:06 xpc3 kernel: loop1         S DBFCBF24     0 22868      1       
       13058 (L-TLB)
Nov 15 11:08:06 xpc3 kernel: Call Trace: [<c0107d21>] __down_interruptible
[kernel] 0x71 (0xf4177f84))
Nov 15 11:08:06 xpc3 kernel: [<c0107dcf>] __down_failed_interruptible [kernel]
0x7 (0xf4177fac))
Nov 15 11:08:07 xpc3 kernel: [<fa449100>] .text.lock.loop [loop] 0x55 (0xf4177fb8))
Nov 15 11:08:07 xpc3 kernel: [<fa447bf0>] loop_thread [loop] 0x0 (0xf4177fc8))
Nov 15 11:08:07 xpc3 kernel: [<c010744e>] kernel_thread [kernel] 0x2e (0xf4177ff0))
Nov 15 11:08:07 xpc3 kernel: [<fa447bf0>] loop_thread [loop] 0x0 (0xf4177ff8))
Nov 15 11:08:07 xpc3 kernel: 
Nov 15 11:08:07 xpc3 kernel: umount        R current      8 22914  22694       
             (NOTLB)
Nov 15 11:08:07 xpc3 kernel: Call Trace: [<c0140d3e>] invalidate_bdev [kernel]
0x5e (0xdbfcbf04))
Nov 15 11:08:07 xpc3 kernel: [<c014560b>] kill_bdev [kernel] 0x1b (0xdbfcbf38))
Nov 15 11:08:07 xpc3 kernel: [<c014648d>] blkdev_put [kernel] 0xad (0xdbfcbf4c))
Nov 15 11:08:07 xpc3 kernel: [<c014455a>] remove_super [kernel] 0x6a (0xdbfcbf68))
Nov 15 11:08:07 xpc3 kernel: [<c015742f>] sys_umount [kernel] 0x3f (0xdbfcbf80))
Nov 15 11:08:07 xpc3 kernel: [<c01574a7>] sys_oldumount [kernel] 0x17 (0xdbfcbfb4))
Nov 15 11:08:07 xpc3 kernel: [<c01090ff>] system_call [kernel] 0x33 (0xdbfcbfc0))
Nov 15 11:08:06 xpc3 kernel: new-kernel-pk S BFFFF3A0     8 22691  22675 22694 
             (NOTLB)
Nov 15 11:08:06 xpc3 kernel: Call Trace: [<c0125b50>] sys_rt_sigaction [kernel]
0xa0 (0xefd21f64))
Nov 15 11:08:06 xpc3 kernel: [<c011e260>] sys_wait4 [kernel] 0x100 (0xefd21f80))
Nov 15 11:08:06 xpc3 kernel: [<c01090ff>] system_call [kernel] 0x33 (0xefd21fc0))
Nov 15 11:08:06 xpc3 kernel: 
Nov 15 11:08:06 xpc3 kernel: mkinitrd      S BFFFF7A0     8 22694  22691 22914 
             (NOTLB)
Nov 15 11:08:06 xpc3 kernel: Call Trace: [<c0125b50>] sys_rt_sigaction [kernel]
0xa0 (0xeed0ff64))
Nov 15 11:08:06 xpc3 kernel: [<c011e260>] sys_wait4 [kernel] 0x100 (0xeed0ff80))
Nov 15 11:08:06 xpc3 kernel: [<c01090ff>] system_call [kernel] 0x33 (0xeed0ffc0))

(sorry for pasting round the wrong way...)


Comment 4 Jeff Johnson 2002-11-15 17:42:07 UTC
rpm has always permitted multiple, even identical,
instances of packages to be installed, that's not
going to change.

open a bug against the kernel package for the
umount problem (if necessary).


Note You need to log in before you can comment on or make changes to this bug.