Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77832 - Installer crashes with anaconda-dump
Summary: Installer crashes with anaconda-dump
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-14 07:26 UTC by udippel
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-14 21:36:32 UTC


Attachments (Terms of Use)
Anaconda-dump (deleted)
2002-11-14 07:27 UTC, udippel
no flags Details

Description udippel 2002-11-14 07:26:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Not much to be said; the anaconda dump should talk for itself

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Install (upgrade) 8.0
2.
3.
	

Actual Results:  Crash of installer

Additional info:

Comment 1 udippel 2002-11-14 07:27:22 UTC
Created attachment 84984 [details]
Anaconda-dump

Comment 2 Colin 2002-11-14 21:36:25 UTC
Unable to install Red Hat,
What can I be doing wrong?

The following report was given while attempting to install redhat 8.0 on an
older machine currently set up with win98. The PC is an HP with 200 mhz, about
48 ram and 20gb hdd.
I have reformatted and reinstalled win98 (upgraded from win95) prior to
attempting to install Red hat 8.0
I am hoping to install Linux on this machine to become familiar with Linux as an
OS before installing on other PCs.
The report has the option to debug? or save to floppy however nothing is
read to a floppy when choosing that option.

EXCEPTION OCCURRED

An unhandled exception has occurred. This is most likely a bug.

Traceback (most recent call last):
File /usr/lib/anaconda/gui.py, line 786, in handleRenderCallback
Self.currentWindow.renderCallback0
File /usr/lib/anaconda/iw/progress_gui.py, line 149, in renderCallback
Self.int.icw.nextClicked0
File /usr/lib/anaconda/gui.py, line 632, in nextClicked
Self.dispatch.gotoNext0
File /usr/lib/anaconda/dispatch.py, line 150, in gotoNext
Self.moveStep0
File /usr/lib/anaconda/dispatch.py, line 215, in moveStep
Rc = apply(func,self.bindArgs(args))
File /usr/lib/anaconda/packages.py, line430 inOnFileSystems
Partitions.doMetaDeletes(diskset)
File /usr/lib/anaconda/partions.py, line1110, in doMetaDeletes
Lvm.vgactiveate0
File /usr/lib/anaconda/lvm.py, line 54 in vgactivate
SearchPath = 1)
File /usr/lib/anaconda/iutil.py, line 66 in execWithRedirect
Chidpid = os.fork0
OSError.[Errno 12] Cannot allocate memory

Please advise, regards Colin


Comment 3 Michael Fulbright 2002-11-14 22:26:05 UTC
You need to remove the 'kernel-smp' package before you attempt an upgrade.

Comment 4 udippel 2002-11-15 01:46:01 UTC
This 'Closed Won'tFix' is a nice escape, isn't it !?
It *must* fix, I'd say, because 
1. I wasn't even aware that it had been installed on that cheapie AMD400
2. An upgrade to 7.3 works flawlessly (do you want to tell me that it is normal
to have less able anacondas in more recent distros?)
3. In any case, the installer should not core dump during upgrade once it
doesn't find what it needs, better: finds what it does not like

Of course, I leave it to you to decide

Comment 5 udippel 2002-11-15 03:11:50 UTC
This 'Closed Won'tFix' is a nice escape, isn't it !?
It *must* fix, I'd say, because 
1. I wasn't even aware that it had been installed on that cheapie AMD400
2. An upgrade to 7.3 works flawlessly (do you want to tell me that it is normal
to have less able anacondas in more recent distros?)
3. In any case, the installer should not core dump during upgrade once it
doesn't find what it needs, better: finds what it does not like

Of course, I leave it to you to decide

Comment 6 Michael Lee Yohe 2003-01-09 14:06:03 UTC
This appears to be a duplicate of Bug 76123.  The problem is that there is not
enough memory to process the transactions that are to be executed by the
installer.  Anaconda, in GUI mode, requires at least 64M+ of memory and 128M of
swap.  

You can alternatively attempt to install Red Hat Linux 8.0 in text mode by
specifying "linux text" at the SYSLINUX prompt upon first boot.  Anaconda, in
text mode, is more lenient on memory resources.


Note You need to log in before you can comment on or make changes to this bug.