Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77828 - Cannot create PDFs
Summary: Cannot create PDFs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openoffice.org
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
: 77829 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-14 05:55 UTC by udippel
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-02-27 16:00:23 UTC


Attachments (Terms of Use)

Description udippel 2002-11-14 05:55:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Had a hard time with OO on RH8.0. Simply doesn't create PDFs. I also posted a
bug report to OpenOffice (http://www.openoffice.org/issues/show_bug.cgi?id=6829)
, but by now it seems it is an integration problem into RH:
In /usr/lib/openoffice/spadmin I created the default printer lpr (a LaserJet)
and the PDF-converter. The user can print to the LaserJet, but no PDF is created
in the target directory. I found, that the PDF had been created in the default
("My Documents") directory. 
Then I ran ~.openoffice/spadmin and set the PDF-directory again, and now nothing
is created nowhere (slocate updated is my friend). Only straightforward printing
to LaserJet still works, even printing to a file is out of question (simply
nothing is produced).
I only renamed the default printer (su) to LaserJet 5 and now LaserJet 5 *and*
the old "Generic Printer" show up in spadmin (user), none of which can be
removed. Okay for the PDF-converter and the LaserJet 5; but how (where) to
remove the former "Generic Printer" which is not available under spadmin (su)
and not removable in spadmin (user). I also set A4 as default for PDF-converter,
but the printer applet always falls back to Letter. A big hole of a mess, by now.

How to reset the settings for spadmin for both su and user?
And then, thereafter: how to make the PDF-converter produce PDFs again?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. (please, see above !)
2.
3.
	

Actual Results:  No printing to file, no PDF-conversion

Expected Results:  Consistent setup (spadmin) for su and user to permit creation
of PDF and printing to a file. Plus a clear reset function that erases all
printers, at least as su.

Additional info:

Comment 1 Jakub Jelinek 2002-11-14 09:58:13 UTC
*** Bug 77829 has been marked as a duplicate of this bug. ***

Comment 2 Dan Williams 2003-12-05 19:31:15 UTC
Can you post the string you have for the PDF coverter from spadmin?

Comment 3 udippel 2003-12-06 02:27:55 UTC
May I deviate somewhat from the topic. please ?
I wouldn't know where else to post this.

You guys are doing a good job, really ! Congratulations !
At times I was impatient, dissatisfied. My excuses.
You are cleaning up very well; probably related to the professional,
commercial background of RedHat.

You're trying to sort out all details that went wrong. Forensics.
Will make RedHat a great success ! Keep going.

Now back to your request: It was like what I posted. On November 14;
more than a year ago. Then OO probably had been some 1.0.something.
Inbetween, we had a few hundered RHN-updates. We also had two (?)
betas of OO 1.1; 5 RCs; 1.1.0 itself.
Of course, my system(s) today are so different, and - honestly - you
cannot expect me to freeze a non-functional state. Just for space, at
a certain moment I had to delete the OO that came with 8.0.
You will understand that I am unable to provide what you asked for.

Kind regards, and keep up the good job !

Uwe

Comment 4 Dan Williams 2004-02-27 16:00:23 UTC
Please try current OOo 1.1.0, and reopen if problem still occurs. 
Specifically, try the File->Export to PDF functionality and see if
that has problems too.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.