Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77810 - Sony SDT-9000 DDS3 Tape Error
Summary: Sony SDT-9000 DDS3 Tape Error
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tar
Version: 8.0
Hardware: noarch
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-13 22:41 UTC by Seth Bardash
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-13 22:41:16 UTC


Attachments (Terms of Use)
0200 Firmware (deleted)
2002-11-13 22:46 UTC, Seth Bardash
no flags Details

Description Seth Bardash 2002-11-13 22:41:08 UTC
Description of Problem:

tar returns multiple errors during its verify stage when creating an archive on 
the Sony SDT-9000

Version-Release number of selected component (if applicable):

Sony SDT-9000 Firmware revision 0601 - latest

How Reproducible:

Every time

Steps to Reproduce:
1. Boot system
2. Load DDS-3 Tape into drive
3. run tar -cvWf /dev/st0 . (I used cwd of /usr/src/linux)

Actual Results:

At the end of this tar I get this error
Verify ./(second to last file)
Tar: /dev/st0: Cannot read Input/output error
Tar: /dev/st0: Cannot read Input/output error
Tar: /dev/st0: Cannot read Input/output error
Tar: /dev/st0: Cannot read Input/output error
Tar: /dev/st0: Cannot read Input/output error
Tar: /dev/st0: Cannot read Input/output error
Tar: /dev/st0: Cannot read Input/output error
Tar: /dev/st0: Cannot read Input/output error
Tar: /dev/st0: Cannot read Input/output error
Tar: /dev/st0: Cannot read Input/output error
Tar: /dev/st0: Cannot read Input/output error
Tar: /dev/st0: Cannot read Input/output error
Tar: Too many errors, quitting
Tar: Error is not recoverable: exiting now


Expected Results:

Expected tar to complete the verify normally and exit

Additional Information:

1) The drive passes all the Windows based Sony tests.
2) Sony has found that down rev'ing the firmware to version 0200
   fixes the problem.
3) Sony is investigating the cause and will fix the firmware - per their FAE.
4) We have seen the same problem on a Sony AIT-1 SDX-300C Drive with Firmware
   Rev 404 - also the latest. Sony is also investigating this.
5) This problem occurs on multiple machines with different SCSI controllers:
   Tested: LSI Logic 53C8xx and 53C1010-33 and Adaptec 29160
   Same problem occured under on all controllers on both RH 7.3 and 8.0
6) All the above mentioned machines work fine with an HP DDS-3 drive on the same
   Controllers running the same software.

Comment 1 Seth Bardash 2002-11-13 22:46:54 UTC
Created attachment 84924 [details]
0200 Firmware


Note You need to log in before you can comment on or make changes to this bug.