Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77797 - lots of unknown 'Other Devices' that are identified by lspci
Summary: lots of unknown 'Other Devices' that are identified by lspci
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Other
Version: RHN Stable
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-13 18:56 UTC by Patrick C. F. Ernzer
Modified: 2007-04-18 16:48 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-20 16:10:12 UTC


Attachments (Terms of Use)
lspci file from sysreport (deleted)
2002-11-13 18:57 UTC, Patrick C. F. Ernzer
no flags Details

Description Patrick C. F. Ernzer 2002-11-13 18:56:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:
System ID: 1001571217 shows a lot of unidentified devices under 'Other Devices'.
Some of these identify fine with lspci

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run sysreport
2. shedule hardware list refresh
3. compare lspci in sysreport to what RHN shows
	

Actual Results:  the following devices are missing:
QLA2300 64-bit FC-AL Adapter
QLA2300 64-bit FC-AL Adapter (yes, there are two)
AHA-3960D / AIC-7899A U160/m
AHA-3960D / AIC-7899A U160/m (yes, there are two)
NetXtreme BCM5701 Gigabit Ethernet
NetXtreme BCM5701 Gigabit Ethernet (yes, there are two)
RAID subsystem HBA
RAID subsystem HBA (yes, there are two)

Whatsmore, at least the QLA2300 are wrong, they are in fact QLA2310F

Expected Results:  Correct display of hardware

Additional info: The other unknown devices are of Class Host bridge, we may want
to put that info into the RHN pages as well as Host bridge is more descriptive
than unknown device.

Comment 1 Patrick C. F. Ernzer 2002-11-13 18:57:00 UTC
Created attachment 84884 [details]
lspci file from sysreport

Comment 2 Adrian Likins 2002-11-13 20:57:29 UTC
whats /etc/sysconfig/hwconf look like? thats where up2date/rhn_register
gets it's hardware info from. 

If it's out of date, sounds more like a kudzu issue (kudzu generates that).

Also, was this system updated? It's possible the system registered
at some point past with less meaningful pci mappins.

Comment 3 Mihai Ibanescu 2003-01-15 15:50:51 UTC
Ping.
up2date takes the information from kudzu. Check Adrian's post.

Comment 4 Patrick C. F. Ernzer 2003-01-20 13:07:41 UTC
pong: it's a customer's machine. As it has not checked into RHN since 2002-12-13
03:41:56 EST getting therequired info from there seems unlikely.

I'll refile this if I can reproduce on a system I have control over. Close for now.


Note You need to log in before you can comment on or make changes to this bug.