Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77796 - Tab completion on directories in bash incorrect
Summary: Tab completion on directories in bash incorrect
Keywords:
Status: CLOSED DUPLICATE of bug 72512
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-13 18:53 UTC by Cort Dougan
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-14 08:42:13 UTC


Attachments (Terms of Use)

Description Cort Dougan 2002-11-13 18:53:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021017

Description of problem:
mkdir foodir
touch foodir/exec
chmod 755 foodir/exec
./foodir<TAB>
and you'll get "./foodir "
The extra space is incorrect since I'm wanting to execute
"./foodir/exec"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.mkdir foodir
touch foodir/exec
chmod 755 foodir/exec
./foodir<TAB>
and you'll get "./foodir "
The extra space is incorrect since I'm wanting to execute
"./foodir/exec"
3.
	

Additional info:

Comment 1 Michael Lee Yohe 2002-11-13 20:19:16 UTC
The path listing isn't updated if you sit in the directory.  If you change to
another directory and then back to the parent directory of foodir - bash will
have updated the tree so that tab completion can work properly. 
mkdir/touch/chmod are not internal to bash and have no conduit of letting bash
know that the directory listing was updated.

Comment 2 Ben Levenson 2002-11-14 01:10:21 UTC

*** This bug has been marked as a duplicate of 72512 ***

Comment 3 Tim Waugh 2002-11-14 08:43:48 UTC
(Oops, shouldn't have re-opened).

*** This bug has been marked as a duplicate of 72512 ***


Note You need to log in before you can comment on or make changes to this bug.