Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77779 - nut--0.45.4 is very different from 0.45.0
Summary: nut--0.45.4 is very different from 0.45.0
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nut
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-13 15:00 UTC by Alain Spineux
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-20 15:23:12 UTC


Attachments (Terms of Use)

Description Alain Spineux 2002-11-13 15:00:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
the use of nut-0.45.4 as changed
The main change is upsmon running as nobody, and cannot read files in /etc/ups 
and create /var/run/upssched.pipe


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install nut as a master
2. Setup a timer
3. start the ups service
3. unplug the power cord of the ups.


Actual Results:  
1. upsmon is started as nobody
2. upsmon don't start properly because it cannot read /etc/ups/upssched.conf 
(use upsmon -d in init.d to enable debuging in syslog)
3. upssched-cmd is not started because upsmon cannot 
create /var/run/upssched.pipe



Additional info:

The solution is to use the -p swith with upsmon in /etc/init.d to not start 
using an unprivileged uid. ( man upsmon )
And for the setup of a timer dont forget to uncomment PIPEFN in 
/etc/ups/upssched.conf

0.45.4 use a noew configuration file 

An better solution could be to use to nut 1.2 !

Comment 1 Ngo Than 2005-07-20 15:23:12 UTC
the problem should be fixed in current FC3/4 release. If it still appears,
please reopen it again. Please change the product to "Fedora Core" and
version to "4" in this case. Thank you very much


Note You need to log in before you can comment on or make changes to this bug.