Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77769 - Latest gtk2 (gtk2-2.1.2-1) lost theme engines
Summary: Latest gtk2 (gtk2-2.1.2-1) lost theme engines
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gtk2
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-13 12:02 UTC by Nicolas Mailhot
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-19 15:58:06 UTC


Attachments (Terms of Use)

Description Nicolas Mailhot 2002-11-13 12:02:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.0.1) Gecko/20021003

Description of problem:
gtk2 gtk2-2.1.2-1 installs itself in /usr/lib/gtk-2.0/2.0.102.

The problem is both gtk2-engines and redhat-artwork install the theme engines in
/usr/lib/gtk-2.0/2.0.0. They are no longer found by new gtk2 resulting in lots
of error messages (since the default theme bluecurve uses a theme engine)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
.

Additional info:

Comment 1 Owen Taylor 2002-11-13 16:19:49 UTC
Known problem, we aren't going to forget about it;

You can create symlinks to fix your problem temporarily.


Comment 2 Nicolas Mailhot 2002-11-13 21:45:00 UTC
Well I did find the workaround all by myself:). In fact I wasn't worried about
this bug but about bug # 77768 (which is why I fired bugzilla in the first place)

This one is just an afterthought.

Keep on the good work !


Comment 3 Bill Nottingham 2002-12-19 15:58:06 UTC
We've since built new gtk-engines, etc.


Note You need to log in before you can comment on or make changes to this bug.