Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77768 - Latest rawhide (9 november) kills gnome session
Summary: Latest rawhide (9 november) kills gnome session
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-session
Version: 1.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-13 11:50 UTC by Nicolas Mailhot
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-09 13:22:50 UTC


Attachments (Terms of Use)

Description Nicolas Mailhot 2002-11-13 11:50:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.0.1) Gecko/20021003

Description of problem:
Upgrading to 9 nov. rawhide caused gnome-session to hang on startup on the two
boxes I've tested (one PIII the other athlon). When using a splash screen it
hangs before any icon is drawn.

Reverting to RH 8.0 Orbit* (+ gconf, bonobo, oaf...) sort of fixes it, gnome
session starts, but lot of gnome parts crash afterwards with  
+ cannot create instance of abstract (non-instantiatable) type `GtkWidget' ;

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Upgrade to 9 nov rawhide ORBit*/gconf*/oaf*/bonobo* rpms.
	

Actual Results:  Useless login (empty blue screen sicne I had disabled splash
screens)

Expected Results:  Normal login

Additional info:

This bug has rendered two stations about useless

(Ok, I know that using rawhide can cut, this is one of the most severe breakages
I've seen so far)

Comment 1 Nicolas Mailhot 2002-12-09 10:11:21 UTC
Still here after all this time, dropped all RH 8.0 throwbacks and went full Raw
Hide.

One of the test boxes has an nfs /home, and login in from a RH 8.0 station works
so it's not a user config problem.

Right now I'm reduced to login in failsafe mode, and launching metacity &
gnome-panel by hand in the xterm like in the good old gnome 0.6 days (plus
usually any control-center applet to load user config)

I am the only one with this ? Since I can reproduce it on two independently
installed stations, this would really surprise me.

Comment 2 Miloš Komarčević 2002-12-09 13:22:42 UTC
I can confirm this bug on two machines here.
I have since gone back to stock RH 8.0 bonobo.

Comment 3 Havoc Pennington 2002-12-09 15:44:25 UTC
Downgrade to bonobo-activation 1.0 (the newer bonobo-activation was backed out, 
maybe it's still stuck in rawhide, I don't know).

It may also work to upgrade to a newer control-center.

The crash about 'GtkWidget' is fixed by upgrading libgnomeui, fwiw.

Anyhow, this is working in our current tree, not sure about the ftp site sync.

Comment 4 Nicolas Mailhot 2002-12-09 16:34:14 UTC
It works, thanks.

Unfortunately none of my rawhide sync scripts understands reverting to an older
version, so I was stuck with the old new buggy one.

Maybe upping the epoch in this case would have helped ?


Note You need to log in before you can comment on or make changes to this bug.