Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77765 - invalid characters breaks a terminal until reset terminal.
Summary: invalid characters breaks a terminal until reset terminal.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: vte
Version: beta1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-13 07:42 UTC by Akira TAGOH
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-13 08:41:25 UTC


Attachments (Terms of Use)

Description Akira TAGOH 2002-11-13 07:42:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Generally EUC-JP doesn't allow Latin1. but such characters often appears onto
the terminal. when it appears unfortunately, terminal window is broken, and it
can't be shown correctly without reset the terminal.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.runs gnome-terminal with LANG=ja_JP.eucJP
2.look at Latin1 characters with something like the pager.
3.
	

Actual Results:  terminal window is broken.

Expected Results:  should ignore such characters as well as previous gnome-terminal.


Additional info:

Comment 1 Nalin Dahyabhai 2003-01-14 04:16:12 UTC
By "ignore", do you mean not to acknowledge that the application sent
unrecognizable text to the terminal?  I wouldn't think that behavior was desirable.

Comment 2 Akira TAGOH 2003-01-14 06:56:41 UTC
I have no idea to handle those characters with EUC-JP. do you think this problem
can be fixed like box drawing issue? if possible, it would be great.

Comment 3 Akira TAGOH 2003-08-13 08:41:25 UTC
It looks good in the current release. I couldn't reproduce it now.


Note You need to log in before you can comment on or make changes to this bug.