Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77759 - cannot create boot diskette with updated smp kernel
Summary: cannot create boot diskette with updated smp kernel
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkbootdisk
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-13 03:28 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-19 06:56:21 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-13 03:28:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
After updating to kernel 2.4.18-17.8.0smp, and using a 1.4 M diskette, the
command "mkbootdisk 2.4.18-17.8.0smp" fails with the error message:

gzip: stdout: No space left on device
cat: write error: No space left on device
cat: write error: No space left on device


Version-Release number of selected component (if applicable):
mkbootdisk-1.4.8-1

How reproducible:
Always

Steps to Reproduce:
1. Fully update i686 smp system.
2. mkbootdisk 2.4.18-17.8.0smp
3. pout.
	

Actual Results:  Process fails with error message:

gzip: stdout: No space left on device
cat: write error: No space left on device
cat: write error: No space left on device

Expected Results:  The process should happily create a bootable diskette with no
complaints.

Additional info:

I just tried, and the "stock" smp kernel (2.4.18-14smp, from the 8.0 CD) also
fails, but with only one "cat" line instead of two...

This means I don't have a boot diskette any more.  :-( :-(

Looks like we'll need some way of tagging or identifying essential modules for
inclusion on the boot diskette.

Another possible option is to ship an image with each kernel (?).

Comment 1 Need Real Name 2002-11-13 03:42:47 UTC
Sorry I didn't call mkbootdisk with the -v flag before... here it is:

[root@helium root]# mkbootdisk -v 2.4.18-17.8.0smp
Insert a disk in /dev/fd0. Any information on the disk will be lost.
Press <Enter> to continue or ^C to abort: 
Formatting /dev/fd0... done.
Copying /boot/vmlinuz-2.4.18-17.8.0smp... done.
Creating initrd image... 
gzip: stdout: No space left on device
done.
Configuring bootloader... cat: write error: No space left on device
cat: write error: No space left on device
done.

And here is what the diskette ends up looking like:

[root@helium test]# mdir a:
 Volume in drive A has no label
 Volume Serial Number is 3DD1-C87A
Directory for A:/

LDLINUX  SYS      7112 11-12-2002  22:35 
VMLINUZ        1203101 10-08-2002  12:06  vmlinuz
INITRD   IMG    253952 11-12-2002  22:36  initrd.img
SYSLINUX CFG         0 11-12-2002  22:36  syslinux.cfg
BOOT     MSG         0 11-12-2002  22:36  boot.msg
        5 files           1 464 165 bytes
                                  0 bytes free



Comment 2 Jeremy Katz 2003-02-19 06:56:21 UTC
There are some improvements to help with this in mkbootdisk-1.5.0-1, but we're
quickly reaching the size limit for floppies.  There's now a --iso flag to
mkbootdisk that will allow you to create a bootable ISO image to use (which
doesn't have these size restrictions) as well.


Note You need to log in before you can comment on or make changes to this bug.