Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77748 - SQL errors are not handled.
Summary: SQL errors are not handled.
Keywords:
Status: CLOSED DUPLICATE of bug 75903
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: unspecified
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Todd Warner
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-12 23:41 UTC by Todd Warner
Modified: 2007-07-31 19:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-09 19:26:29 UTC


Attachments (Terms of Use)

Description Todd Warner 2002-11-12 23:41:00 UTC
When an SQL error occurs, they are not handled really well. One must look in the
logs to actually see them, and sometimes the sync tool tries to continue, even
though all SQL errors are fatal.

Comment 1 Todd Warner 2002-11-12 23:43:12 UTC
Fixed in CVS... no QA as of yet...

o SQLError, SQLSchemaError, and SQLCommunicationError errors are caught.
o assumption that all such errors are fatal is made.

Comment 2 Todd Warner 2002-12-09 19:26:21 UTC
Never QA'ed; reopening... and tracking

Comment 3 Todd Warner 2002-12-09 20:07:44 UTC

*** This bug has been marked as a duplicate of 75903 ***


Note You need to log in before you can comment on or make changes to this bug.