Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7772 - Can't mount ISO-9660 CD-ROM after playing music CD
Summary: Can't mount ISO-9660 CD-ROM after playing music CD
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mount
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-12 18:02 UTC by Rob McMillin
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-12-21 18:15:20 UTC


Attachments (Terms of Use)

Description Rob McMillin 1999-12-12 18:02:24 UTC
On RedHat 6.1, using an Afreey 45x IDE CD-ROM drive, whenever I play a
music CD-ROM, I can never afterwards mount a data CDROM (RedHat 6.1
distribution CD, say).  Here's the error I see:

mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
       or too many mounted file systems

Of course, the problem goes away if I reboot.

If it makes any difference, I'm using the SMP kernel on a multi-CPU system.

Comment 1 Riley H Williams 1999-12-12 21:16:59 UTC
Does your kernel have iso9660 compiled as a module by any chance?

If so, is the above also true if you run the following command between playing
the music CD and trying to mount a data CD:

    modprobe iso9660


------- Email From  Rob McMillin <robm@pricegrabber.com> 12/12/99 16:55 -------
Attached to Bug # 7772.


------- Email From  Rob McMillin <robm@pricegrabber.com> 12/12/99 16:57 -------
Attached to Bug # 7772.

Comment 2 Riley H Williams 1999-12-12 22:14:59 UTC
Rob McMillin <robm@pricegrabber.com> asks:

 Q> How would I know this?

Three tests for you to do:

 1. Type `grep iso9660 /proc/filesystems | wc -l` and advise.

 2. If the above returned zero, type `modprobe iso9660` and
    then repeat test 1. Do not repeat this more than once.

 3. Type `lsmod | grep iso9660 | wc -l` and advise.

Analyse the results as follows:

    Test 1    Test 2    Test 3    Result
    ~~~~~~    ~~~~~~    ~~~~~~    ~~~~~~
       0         0         0      Not compiled or not available
       0         0         1      Impossible combination
       0         1         0      Impossible combination
       0         1         1      Compiled as a module
       1         0         0      Impossible combination
       1         0         1      Impossible combination
       1         1         0      Hard compiled into kernel (Monolithic)
       1         1         1      Compiled as a module

Basically, if you get either of the "Compiled as a module" lines (or even if you
don't), try playing a music CD, take the music CD out of the drive, issue the
stated command of `modprobe iso9660` and then insert a data CD in the drive and
try to mount that and report on the result.

------- Email From  Rob McMillin <robm@pricegrabber.com> 12/12/99 17:40 -------
Attached to Bug # 7772.

Comment 3 Bernhard Rosenkraenzer 1999-12-17 15:33:59 UTC
Looks like your audio CD player doesn't correctly release the CD when it's done
playing... Which CD player are you using?
Does it still happen if you use a different one?

Comment 4 Riley H Williams 1999-12-21 18:15:59 UTC
Q> Okay, so it looks like the answer is "Hard compiled into kernel
 Q> (Monolithic)".

That tends to imply that it's something the drive is doing, rather than anything
the kernel is doing.

One thing you might wish to try is to compile a kernel with the iso9660 file
system comiled as a module, then try the following:

 1. Use a data CD, then play a music CD, then unload the iso9660 fs
    driver, then load the iso9660 fs driver, then use a data CD.

 2. Use a data CD, then unload the iso9660 fs driver, then play a
    music CD, then load the iso9660 fs driver, then use a data CD.

If one of the above works and the other doesn't, that could easily give one of
the developers a clue as to precicely what the problem is.

Comment 5 Bernhard Rosenkraenzer 2000-08-08 15:18:39 UTC
Closing due to lack of user input


Note You need to log in before you can comment on or make changes to this bug.