Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77707 - No callbacks exist for user compiled programs
Summary: No callbacks exist for user compiled programs
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openmotif
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-12 16:04 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-12 16:04:33 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-12 16:04:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
All of my Motif programs produce the following message for every
XtAddCallback().  These are programs that have worked 5-8 years.

Warning: Cannot find callback list in XtAddCallback

Using stock RH 8.0.  Link line:

gcc -g  -I/jnet/linux/include -I/usr/X11R6/include Xwin.o cb_ac.o cb_file.o
cb_edit.o cb_proj.o dsm.o fork.o globals.o hardwire.o hdrbld.o init.o log.o
menu.o opMenu.o projFile.o pms.o setNav.o setOther.o setSh.o setPMS.o sort.o
-L/usr/X11R6/lib -L/jnet/linux/lib -lVarDB -lpms -lAircraft -lraf -lhdr_api -lXm
-lXp -lXt -lXext -lX11 -o hdrbld


Version-Release number of selected component (if applicable):
2.2.2-12

How reproducible:
Always

Steps to Reproduce:
1. Compile a motif program with callbacks.
2. Run said program.

Actual Results:  No buttons or menu items appear on program, some 500 of the
following messages appear:

Warning: Cannot find callback list in XtAddCallback
Warning: Cannot find callback list in XtAddCallback
Warning: Cannot find callback list in XtAddCallback

Additional info:

Comment 1 Need Real Name 2002-11-13 15:06:56 UTC
Turns out a copy of openmotif 2.1 include/Xm was copied over and was searched
before /usr/X11R6/include/Xm.


Note You need to log in before you can comment on or make changes to this bug.