Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77703 - Fixed MM semaphore file path prohibits starting up unprivileged apache instances
Summary: Fixed MM semaphore file path prohibits starting up unprivileged apache instances
Keywords:
Status: CLOSED DUPLICATE of bug 37233
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-12 14:13 UTC by Francesco Chemolli
Modified: 2007-04-18 16:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:08 UTC


Attachments (Terms of Use)

Description Francesco Chemolli 2002-11-12 14:13:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020721

Description of problem:
The EAPI MM apache extension, applied as a patch to the pristine Apache HTTP
server sources, contains a fixed path for the semaphore file, pointing to
/var/run/httpd.mm.$pid. If the file cannot be opened, apache refuses to start up.
This fact prohibits starting up a system-installed apache from an unprivileged
account. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Fire up apache (with an alternative ServerRoot) as any non-root account.
	

Actual Results:  Apache doesn't start, complains: 

Ouch! ap_mm_create(1048576, "/var/run/httpd.mm.26391") failed
Error: MM: mm:core: failed to open semaphore file (Permission denied): OS: No
such file or directory


Expected Results:  Apache should have started up.

Additional info:

At least two different strategies should be performed:

- using some configuration directive or environment variable to override the
compile-time default.
- in case the semaphore file cannot be opened, do not die, but simply do not use
the mm-provied features. This _is_ possible, as demonstrated by the fact that
Apache doesn't contain those features in the first place.

Comment 1 Joe Orton 2003-01-16 17:31:06 UTC
*** Bug 80923 has been marked as a duplicate of this bug. ***

Comment 2 Joe Orton 2003-01-16 17:35:51 UTC
The good fix for this is to make EAPI_MM_CORE_PATH server-root relative; e.g.
add a symlink /etc/httpd/run -> /var/run and use EAPI_MM_CORE_PATH="run/httpd.mm".

Comment 3 Joe Orton 2004-09-21 10:25:49 UTC

*** This bug has been marked as a duplicate of 37233 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:50:08 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.