Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77700 - up2date reports corrupt database
Summary: up2date reports corrupt database
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date
Version: 7.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-12 12:59 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-27 00:27:14 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-12 12:59:17 UTC
Description of Problem:

When i run up2date and it downloads updates, up2date exits with an error 
message.

Version-Release number of selected component (if applicable):

up2date-2.8.39-1.7.0

Steps to Reproduce:
1. notice there is an update available
2. run "up2date-nox -u" in a terminal
3. receive error message.

Actual Results:

Installing...
   1:php                    ########################################### 
[100%]
   2:php-manual             ########################################### 
[100%]
rpmdb: Suspiciously high nelem of 4294967294 on page 0
error: db4 error(-30979) from db->verify: DB_VERIFY_BAD: Database 
verification failed

Expected Results:

No error message.

Additional Information:
	
this could be corruption to the database caused by up2date crashing at some 
point?

(It appears that the files are successfully installed, but it is annoying, 
and a sign that something is/was wrong.

Comment 1 Adrian Likins 2003-08-06 22:54:23 UTC
This looks to be crash related. A `rpm --rebuilddb` should fix it.


Note You need to log in before you can comment on or make changes to this bug.