Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77690 - Loosing init string in Network Configuration Tool when string contains an equals sign
Summary: Loosing init string in Network Configuration Tool when string contains an equ...
Keywords:
Status: CLOSED DUPLICATE of bug 81371
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-12 05:04 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:08 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-12 05:04:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-3 i686)

Description of problem:
Network Configuration fails to parse Init3 strings which contain an equals sign
- sets the initialization string to zero length instead

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Gnome (icon)... Programs... System... Network Configuration
2.Add... Modem Connection... Next
3.Phone Number: 123, Provider Name: 123, Login Name: 123, Password: 123  Next...
Finish
4.Choose 123, Edit... Advanced(tab)
5.Set Initialization String: AT+CGDCONT   OK... Apply... Close
6.Repeat step 1
7.Select device 123   Edit... Advanced(tab)
8.Verify Initialization String is okay
9.Open /etc/wvdial.conf in your favourite editor
10.Locate section [Dialer 123]
11.Locate entry Init3
12.Append "=1"
13.Save file, and close
14.Repeat steps 1 and 7
15.Verify that the Initialization string is now blank (=bug)

Actual Results:  Initialization string blank

Expected Results:  Initialization string should read AT+CGDCONT=1

Additional info:

There seems to be bug associated with
/usr/share/redhat-config-network/netconfpkg/NCDialup.py in the way that it
handles the Init3 string.

Comment 1 Phil Knirsch 2003-02-07 12:48:26 UTC
Reassigning to correct component.

Read ya, Phil

Comment 2 Harald Hoyer 2003-02-07 12:50:43 UTC

*** This bug has been marked as a duplicate of 81371 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:08 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.