Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77685 - ping -n -c1 unreachable address hangs forever
Summary: ping -n -c1 unreachable address hangs forever
Keywords:
Status: CLOSED DUPLICATE of bug 68919
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: iputils
Version: 8.0
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-12 00:03 UTC by Stephen Collier
Modified: 2015-03-05 01:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-12 00:04:01 UTC


Attachments (Terms of Use)

Description Stephen Collier 2002-11-12 00:03:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 95)

Description of problem:
ping -n -c1 <unreachable address> hangs forever and hangs the sensing 
application that depends on it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.ping -n -c1 <unreachable address>
2.sit back and wait
3.
	

Actual Results:  ping -n -c1 192.168.1.160
PING 192.168.1.160 (192.168.1.160) from 192.168.1.164 : 56(84) bytes of data.
From 192.168.1.164 icmp_seq=1 Destination Host Unreachable

Expected Results:  program returns

Additional info:

Comment 1 giulioo 2002-11-12 11:31:27 UTC

*** This bug has been marked as a duplicate of 68919 ***


Note You need to log in before you can comment on or make changes to this bug.