Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77678 - Add a cautionary note to select man page
Summary: Add a cautionary note to select man page
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: man-pages
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-11 22:23 UTC by Ben Woodard
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version: 1.67
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-20 18:41:52 UTC


Attachments (Terms of Use)
Add's a cautionary note to the select man page. (deleted)
2002-11-11 22:24 UTC, Ben Woodard
no flags Details | Diff

Description Ben Woodard 2002-11-11 22:23:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
If you recompile your kernel to allow >1024 file descritors and you leave glibc
the same and then you try to use select on a file descriptor >1024 then select
corrupts memory.

It was decided that because of the unusual setup for this it really wasn't a bug
that should be fixed in glibc. However, documenting around it is probably a good
idea.

Attached is a patch to the manpage.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Note that man page doesn't warn you about the possible problems
2.
3.
	

Additional info:

Comment 1 Ben Woodard 2002-11-11 22:24:29 UTC
Created attachment 84586 [details]
Add's a cautionary note to the select man page.

Comment 2 Eido Inoue 2004-08-20 18:41:52 UTC
upstream in 1.67 it appears.


Note You need to log in before you can comment on or make changes to this bug.