Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77651 - Seagate 80GB (ST380020ACE) harddrive not usable (Installation)
Summary: Seagate 80GB (ST380020ACE) harddrive not usable (Installation)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: i586
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-11 14:58 UTC by Carsten Meyer
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-19 12:24:12 UTC


Attachments (Terms of Use)
The kernel patch from James Finnie (deleted)
2002-11-19 12:24 UTC, Carsten Meyer
no flags Details

Description Carsten Meyer 2002-11-11 14:58:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
The kernel does not recognize the drive. This problem occours during
installation (partitioning with DiskDruid or fdisk is impossible because the
kernel has nothing to partion). The problem has to do with the kernel version an
the disks firmware (see below).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. try to install RedHat 8.0 on the drive from CD/Floppy
2. Installation aborts when you try to partition the disk
3. -> Kernel sees wrong geometry with 0 cylinders (size of the drive could not
be determined).
	

Actual Results:  abort of installation (anaconda wants to reboot)

Additional info:

The drives firmware falsely tells the kernel it is capable of LBA 48 adressing.
That is wrong. The kernel tries to send some LBA 48 commands and the drive
errors. Kernel versions <2.4.18 worked ok. Disk geometry is reported with 0
cylinders due to wrong drive size recognition. Specifying geometry at the boot
prompt does not help. "nodma" does not help.

There was a patch posted by James Finnie (jf1@IMERGE.co.uk) on
newsgroup lucky.linux.kernel (17th October 2002)

Comment 1 Arjan van de Ven 2002-11-11 15:00:48 UTC
what controller is the disk connected to ?

Comment 2 Carsten Meyer 2002-11-11 15:08:04 UTC
The drive is connected to the onboard IDE controler (connected as primary
master). The Board is an ASUS P2B-S with an Intel BX440 chipset.

Comment 3 Carsten Meyer 2002-11-19 12:24:06 UTC
Created attachment 85549 [details]
The kernel patch from James Finnie

Comment 4 Alan Cox 2002-11-19 13:04:54 UTC
Such a change for an apparently faulty device is much much too risky for a
production grade operating system. If someone takes such a fix properly though
the 2.5 development tree so it gets broad testing then it might be something to
look at but not currently.

Closing as NOTABUG, since the problem seems to be the drive firmware. Perhaps
Seagate have fixed firmware by now?



Note You need to log in before you can comment on or make changes to this bug.