Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7765 - kappfinder bug
Summary: kappfinder bug
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
: 8847 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-12 09:35 UTC by Andrea Sterbini
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-06 16:18:52 UTC


Attachments (Terms of Use)

Description Andrea Sterbini 1999-12-12 09:35:54 UTC
The /usr/bin/kappfinder script has a small bug, it uses the variable
${install_root} that's not working properly in RH6.0 and RH6.1.
(I have checked this only against i386 architecture)

FIX: apply the patch below:
<pre>

*** /usr/bin/kappfinder.orig    Fri Sep 24 19:19:20 1999
--- /usr/bin/kappfinder.my      Tue Nov  9 23:39:45 1999
***************
*** 33,38 ****
    INSTPATH=$1 # ignored the more or the less
!   kde_icondir=`echo '${install_root}/usr/share/icons' | sed -e
's#\$KDEDIR#/usr#'`
!   kde_appsdir=`echo '${install_root}/usr/share/applnk' | sed -e
's#\$KDEDIR#/usr#'`
!   kde_minidir=`echo '${install_root}/usr/share/icons/mini' | sed -e
's#\$KDEDIR#/usr#'`
!   kde_largedir=`echo '${install_root}/usr/share/icons' | sed -e
's#\$KDEDIR#/usr#'`
  fi
--- 33,38 ----
    INSTPATH=$1 # ignored the more or the less
!   kde_icondir=`echo '/usr/share/icons' | sed -e 's#\$KDEDIR#/usr#'`
!   kde_appsdir=`echo '/usr/share/applnk' | sed -e 's#\$KDEDIR#/usr#'`
!   kde_minidir=`echo '/usr/share/icons/mini' | sed -e 's#\$KDEDIR#/usr#'`
!   kde_largedir=`echo '/usr/share/icons' | sed -e 's#\$KDEDIR#/usr#'`
  fi
***************
*** 53,55 ****
  OLDDIR=`pwd`
! cd `echo '${install_root}/usr/share/apps' | sed -e
's#\$KDEDIR#/usr#'`/kappfinder

--- 53,55 ----
  OLDDIR=`pwd`
! cd `echo '/usr/share/apps' | sed -e 's#\$KDEDIR#/usr#'`/kappfinder

</pre>

Comment 1 Riley H Williams 1999-12-12 21:47:59 UTC
For those that aren't used to that form of patch, here's the same patch in standard unified diff format:

===8<=== CUT ===>8===

--- /usr/bin/kappfinder.orig    Fri Sep 24 19:19:20 1999
+++ /usr/bin/kappfinder.my      Tue Nov  9 23:39:45 1999
@@ -33,38 +33,38
    INSTPATH=$1 # ignored the more or the less
-   kde_icondir=`echo '${install_root}/usr/share/icons' | sed -e 's#\$KDEDIR#/usr#'`
-   kde_appsdir=`echo '${install_root}/usr/share/applnk' | sed -e 's#\$KDEDIR#/usr#'`
-   kde_minidir=`echo '${install_root}/usr/share/icons/mini' | sed -e 's#\$KDEDIR#/usr#'`
-   kde_largedir=`echo '${install_root}/usr/share/icons' | sed -e 's#\$KDEDIR#/usr#'`
+   kde_icondir=`echo '/usr/share/icons' | sed -e 's#\$KDEDIR#/usr#'`
+   kde_appsdir=`echo '/usr/share/applnk' | sed -e 's#\$KDEDIR#/usr#'`
+   kde_minidir=`echo '/usr/share/icons/mini' | sed -e 's#\$KDEDIR#/usr#'`
+   kde_largedir=`echo '/usr/share/icons' | sed -e 's#\$KDEDIR#/usr#'`
  fi
@@ -53,55 +53,55
  OLDDIR=`pwd`
- cd `echo '${install_root}/usr/share/apps' | sed -e 's#\$KDEDIR#/usr#'`/kappfinder
+ cd `echo '/usr/share/apps' | sed -e 's#\$KDEDIR#/usr#'`/kappfinder

===8<=== CUT ===>8===

Comment 2 Bernhard Rosenkraenzer 2000-02-06 16:18:59 UTC
Thanks, fixed.

Comment 3 Bernhard Rosenkraenzer 2000-02-06 19:13:59 UTC
*** Bug 8847 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.