Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77637 - Redhat-config-Language dialog is blank
Summary: Redhat-config-Language dialog is blank
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-language
Version: 8.0
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-11 08:33 UTC by Michael Goll
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-25 14:30:28 UTC


Attachments (Terms of Use)

Description Michael Goll 2002-11-11 08:33:24 UTC
Description of Problem:

When I enter redhat-config-language, it brings up a pretty box titled "Language
Selection" with a message "Please select the default language for the system"

The selection area is entirely blank and the only thing you can do is press OK.


Version-Release number of selected component (if applicable):

redhat-config-language-1.0.1-6


How Reproducible:

Enter redhat-config-language


Steps to Reproduce:
1. redhat-config-lanugage
 

Actual Results:

a box with no entries


Expected Results:

a box with various languages to choose from


Additional Information:

Comment 1 Brent Fox 2002-11-15 20:07:04 UTC
2 questions:

1) Was this an upgrade from a previous install?

2) What does /etc/sysconfig/i18n contain?

Comment 2 Michael Goll 2002-11-15 22:27:14 UTC
Hi,

Thanks for the tip

Here's what I had in /etc/sysconfig/i18n

#LANG="en_US.UTF-8"
LANG="en_US"
#LANG must be a two letter ISO code per sysconfig.txt
#LANG="en_US.ISO-8859-15"
SUPPORTED="fr_FR@euro:en_US"
SYSFONT="lat0-16"
SYSFONTACM="iso15"

When I removed everything except the LANG="en_US" line, redhat-config-language
worked and created this:

LANG="en_US.UTF-8"
SYSFONT="latarcyrheb-sun16"

Do you suppose it could at least issue an error message along the lines of 
"Unable to process format of /etc/sysconfig/i18n"?

Thanks!

Take care...
Michael



Comment 3 Brent Fox 2002-12-15 15:52:24 UTC
The problem is that the "@euro" on the end of the 'fr_FR@euro' is confusing the
parser.  I will try to fix this now.

Comment 4 Brent Fox 2002-12-15 16:01:29 UTC
Should be fixed in redhat-config-language-1.0.1-10.  Thanks for your report. 
QA, please verify.

Comment 5 Brent Fox 2003-05-25 14:30:28 UTC
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.


Note You need to log in before you can comment on or make changes to this bug.