Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77635 - Undefined symbole in /usr/lib/libmyodbc.so
Summary: Undefined symbole in /usr/lib/libmyodbc.so
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: MyODBC
Version: 8.0
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Patrick Macdonald
QA Contact:
URL:
Whiteboard:
: 78879 80127 86123 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-11 08:07 UTC by Chen Xiangyang
Modified: 2008-05-01 15:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-26 19:10:32 UTC


Attachments (Terms of Use)

Description Chen Xiangyang 2002-11-11 08:07:55 UTC
Description of Problem:  
 
/usr/lib/libmyodbc-2.50.39.so from MyODBC-2.50.39-7.i386.rpm is not usable because there is 
an undefined symbol: 
 
# prog 
prog: relocation error: /usr/lib/libmyodbc.so: undefined symbol: _init_dynamic_array  
 
But the version rebuilt from MyODBC-2.50.39-7.src.rpm works :-) 
 
Version-Release number of selected component (if applicable):  
2.50.39-7  
  
How Reproducible:  
Run a program that uses ODBC driver for MySQL  
   
Actual Results:  
The error line aboved and the program exits. 
  
Expected Results:  
Normal running of the program.  
  
Additional Information:  
None

Comment 1 Martin Norback 2003-01-10 14:42:32 UTC
This seems like an upstream bug, fixed in debian at least.

http://archive.jsw4.net/mysql/02-06/msg00434.html
http://bugs.debian.org/149952
http://www.geocrawler.com/archives/3/13/2002/6/0/9017183/

Comment 2 Patrick Macdonald 2003-02-13 17:14:19 UTC
*** Bug 78879 has been marked as a duplicate of this bug. ***

Comment 3 Patrick Macdonald 2003-02-13 17:15:59 UTC
*** Bug 80127 has been marked as a duplicate of this bug. ***

Comment 4 Alex Butcher 2003-02-14 23:15:37 UTC
The MyODBC src.rpm needs to be rebuilt against the current errata release of MySQL.

Comment 5 Patrick Macdonald 2003-03-25 20:22:12 UTC
I guess this one is mine now.  As noted by Alex Butcher, it needs to be 
rebuilt against the current errata version of MySQL. 


Comment 6 Patrick Macdonald 2003-03-26 19:10:32 UTC
Fixed for 8.0.  I'll push this out in an erratum (which has just been opened).
MyODBC-2.50.39-8.80.i386.rpm

Comment 7 Tom Lane 2004-03-09 01:30:06 UTC
*** Bug 86123 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.