Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77626 - xclock ignores font specification?
Summary: xclock ignores font specification?
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-11 06:40 UTC by Jonathan Kamens
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-12 07:13:48 UTC


Attachments (Terms of Use)

Description Jonathan Kamens 2002-11-11 06:40:24 UTC
I just upgraded to XFree86-tools-4.2.99.2-0.20021105.2 and associated packages
with the same version number.  Now xclock appears to be ignoring all attempts to
set its font. Mind you, editres shows that the font resource on the clock widget
has been set, but no matter what I set it to xclock comes up in the same font
when run with -digital.  I don't know whether this problem is specific to xclock
or indicative of a larger problem (although I haven't yet noticed font problems
in any other X applications).

Comment 1 Mike A. Harris 2002-11-12 06:47:33 UTC
I wasn't sure about wether or not this is a bug so I asked Keith...

<keithp> xclock now uses render by default.  Set the font with '-fa'.
<keithp> Or use -norender
<mharris> So that one isn't a bug then, just a change in behaviour?
<keithp> Yup.  Gotta move forward and stop using '-fn' :-)
<mharris> Ok, sounds good to me.  Thanks.
<keithp> NOTABUG

So this is a feature, and not a bug.  Closing NOTABUG.

Comment 2 Jonathan Kamens 2002-11-12 07:12:39 UTC
There is still a bug here, although I admit that it's not clear exactly what the
bug is.  Some remaining issues:

* The xclock man page doesn't mention -face or the "face" X resource.
* Xterm defaults to old-style fonts and only does rendering if a face is
specified.  Why doesn't xclock behave the same way?
* Xterm provides the -fs command-line option and the faceSize X resource for
setting the freetype face size.  Xclock, on the other hand, appears to provide
no way whatsoever to set the face size.
* Is freetype rendering and faces in X applications documented anywhere?  I
certainly couldn't find it.  Note, for example, the documentation of common
options in X(7x).  If -face is going to be standard in the future, it needs to
be documented there.


Comment 3 Jonathan Kamens 2002-11-12 07:13:42 UTC
Oh, and the usage message that you get when you do "xclock -help" doesn't
mention "-norender".


Comment 4 Mike A. Harris 2002-11-12 10:55:27 UTC
All of the questions you have asked are quite interesting, however
I do not know the answers.  I am not going to simply be a middleman
in between yourself and XFree86.org for answering them.

Please ask these questions on xpert@xfree86.org or fonts@xfree86.org
user mailing lists.  Bugzilla is not a question forum or tech support
forum.

Also, don't reopen a closed bug report and add new data to it as a new
report.  If you've got a new bug to report, open a new bug report.

For each of the bulleted items in your last comment, either it is
a question for XFree86.org, or it is a issue that it is up to them
to determine if it is a bug or not, and if so, it is up to them to
fix it.

xclock is a trivial application, not worth wasting my time.  If it is
that problematic, it is _gone_.


Comment 5 Mike A. Harris 2002-11-12 11:03:07 UTC
Also, missing things in manpages and stuff like that should be reported
to XFree86.org.  I've stated numerous times that extreme trivia should
be reported upstream.

As for freetype, I don't even care if freetype itself has any documentation
at all.  I am not a freetype developer, documentor, packager, I don't
maintain freetype, I don't use freetype in my own code, and I don't even
look at freetype's source code, or documentation.  The place to ask
freetype questions is some mailing list dangling off of www.freetype.org


Note You need to log in before you can comment on or make changes to this bug.