Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77622 - Display Settings Dialog should use Slider, not Radio Buttons
Summary: Display Settings Dialog should use Slider, not Radio Buttons
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL: http://tkmame.retrogames.com/DisplayS...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-11 04:57 UTC by Christopher Stone
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-25 14:29:40 UTC


Attachments (Terms of Use)
screenshot of the new UI (deleted)
2003-01-06 02:56 UTC, Brent Fox
no flags Details

Description Christopher Stone 2002-11-11 04:57:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Anyone who has a large number of screen resolutions is going to get a messed up
dialog box as shown in the picutre provided in the URL section above.  The
display settings should be a slider widget, not a group of radio buttons.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Add about 30 modelines to your CXF86Config file
2.  Open the Change Display dialog box
3.  Observe how the dialog box does not even fit on the screen.
	

Actual Results:  The massive number of radio buttons causes the dialog box to
become so large that it no longer fits onto my screen.

Expected Results:  The display modes should be selectable from a slider widget
so that all your display resolutions will fit within the dialog box no matter
how many are set.

Additional info:

Comment 1 Christopher Stone 2002-11-11 05:40:11 UTC
I just saw a picture of how OS X does it.  OS X uses a fixed length listbox with
a scrollbar.  This also would be an acceptable solution.

Comment 2 Alexander Larsson 2002-11-11 11:12:18 UTC
It should probably also filter out some of the resolutions...


Comment 3 Christopher Stone 2002-11-11 19:28:53 UTC
If you do decide to filter out resolutions below 640x480 there should be a
checkbox to display them (the checkbox would only be visible if resolutions are
actually filtered).  There are times when I like to zoom in on a windows (say a
movie or game) and changing to a resoultion below 640x480 should be an option
from the GUI if you have those modelines in your X config file.

Comment 4 Brent Fox 2003-01-06 02:56:06 UTC
I've decided not to filter out any of the resolutions, mainly because I think it
is pretty uncommon for people to have so many modelines in their config file.

I have replaced the RadioButtons with OptionMenus, so this will accomodate
systems with many mode lines just fine.  I will attach a screenshot.

This should appear in redhat-config-xfree86-0.7.1-1, which should appear in
Rawhide soon.  QA, please verify.

Comment 5 Brent Fox 2003-01-06 02:56:48 UTC
Created attachment 89147 [details]
screenshot of the new UI

Comment 6 Peter van Egdom 2003-03-15 11:36:18 UTC
Added a lot of display modes to my "/etc/X11/XF86Config" file and tried out
"redhat-config-xfree86".

The OptionMenus seems to work fine in presenting the different resolutions, much
better than in the old version (http://tkmame.retrogames.com/DisplaySettings.png).

Verified fixed with "redhat-config-xfree86-0.7.3-2" on Phoebe 8.0.94.

Comment 7 Brent Fox 2003-05-25 14:29:40 UTC
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.


Note You need to log in before you can comment on or make changes to this bug.