Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77608 - restore does not support -Q flag
Summary: restore does not support -Q flag
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dump
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-10 19:10 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-24 07:23:20 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-10 19:10:32 UTC
Description of Problem:
restore from dump 0.4b28 should support the -Q (qfa file) flag, but does not.

Version-Release number of selected component (if applicable):
dump 0.4b28-4

How Reproducible:
Reproducable

Steps to Reproduce:
1. run 'restore -Q <qfa file> -if <dump file>'
2. 
3. 

Actual Results:
Usage message

Expected Results:
Interactive restore session

Additional Information:

Comment 1 Mike A. Harris 2002-11-11 02:19:27 UTC
Please report to upstream dump maintainer using the bug submission form
and guidelines found at:  http://dump.sourceforge.net


Comment 2 Stelian Pop 2002-11-15 10:56:40 UTC
Well, this is not an upstream bug but a Red Hat packaging bug: --enable-qfa
option is missing from the %configure line in the spec file.

While we are at it, you should really update to the latest version of dump
(0.4b32), is has quite some improvements and bugfixes wrt 0.4b28.

Stelian.

Comment 3 Mike A. Harris 2003-01-24 06:59:55 UTC
Well actually... it looks like it is not a bug at all.   If the upstream
sources do not enable an option by default, then it is assumed that that
option is non-default behaviour.

That would make this neither an upstream bug, nor a Red Hat packaging bug.
It would make it a feature not enabled by default in upstream sources, nor
in Red Hat packaging.

This is thus a feature enhancement request more than a bug report.  Changing
the severity to Enhancement.

Comment 4 Mike A. Harris 2003-01-24 07:23:20 UTC
Feature enhancement made to dump-0.4b28-7 in rawhide




Note You need to log in before you can comment on or make changes to this bug.