Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77607 - Can't view man pages when running screen
Summary: Can't view man pages when running screen
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: screen
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-10 18:56 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-11 16:40:47 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-10 18:56:55 UTC
Description of Problem:
If you are running screen, some man pages are truncated and man becomes 
unusable.  It seems that some man pages are generating escape sequences that 
are not supported by screen.  This makes man completely unusable under screen.

Version-Release number of selected component (if applicable):
man 1.5j-11
screen 3.9.11-10

How Reproducible:
Reproducable

Steps to Reproduce:
1. Run 'screen'
2. Run 'man dump'

Actual Results:
Partial man page, no 'less' promp, unresponsive to keyboard input.

Expected Results:
Complete man page, 'less' prompt, responsive to keyboard input.

Additional Information:
'dump' man page one of many that seem to break under screen.  Try a few to find 
more.

Comment 1 Leonid Mamtchenkov 2002-11-10 23:48:56 UTC
Try different values for you TERM environment variable for starters:
export TERM=linux
man dump

export TERM=xterm
man dump

export TERM=vt100
man dump

Comment 2 Need Real Name 2002-11-11 01:27:18 UTC
All three TERM settings fail as reported.  Confirmed both on console and putty 
ssh.

Comment 3 Lon Hohberger 2002-11-11 14:35:24 UTC
We built screen without UTF-8 support in Red Hat Linux 8.0.  This is because the
UTF-8 support in screen was causing more problems than it solves.  So, to fix
this, we need to tell other programs not to use UTF-8 languages (which confuse
screen):

screen

export LANG=en  (or LANG=C)

man dump

Should work.  You could put the "export LANG=en" in your .bashrc.

Comment 4 Need Real Name 2002-11-11 16:40:40 UTC
Changing LANG solves problems.  Thanks for quick reply.


Note You need to log in before you can comment on or make changes to this bug.