Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77598 - Installer says cannot allocate memory
Summary: Installer says cannot allocate memory
Keywords:
Status: CLOSED DUPLICATE of bug 76123
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-10 08:33 UTC by Ryan Djurovich
Modified: 2007-04-18 16:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:07 UTC


Attachments (Terms of Use)

Description Ryan Djurovich 2002-11-10 08:33:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Once I have selected all of my preferences for the installation, I press next 
and the screen that displays all of the packages that are being installed 
appears, before it starts installing I get an error titled 'Exception Occured'.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start annaconda Installer
2.Select Preferences
3.Start Installation
	

Actual Results:  It showed an error message, not allowing me to continue.

Expected Results:  Linux should have started installing.

Additional info:

Traceback (most recent call last):
 File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback
  self.currentWindow.renderCallback()
 File "/usr/lib/anaconda/iw/progress_gui.py", line 149, in renderCallback
  self.intf.icw.nextClick ed()
 File "/usr/lib/anaconda/gui.py", line 632, in nextClicked
  self.dispatch.gotoNext()
 File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
  self.moveStep()
 File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
  rc = apply(func, self.bindArgs(args))
 File "/usr/lib/anaconda/packages.py", line 430, in turnOnFilesystems
  partitions.doMetaDeletes(disket)
 File "/usr/lib/anaconda/packages.py", line 1110, in doMetaDeletes
  lvm.vgactivate()
 File "/usr/lib/anaconda/lvm.py", line 54, in vgactivate
  searchPath = 1)
 File "/usr/lib/anaconda/lutil.py", line 66, in execWithRedirect
  childpid = os.fork()
OSError: [Errno 12] Cannot allocate memory

Comment 1 Michael Fulbright 2002-11-11 15:38:34 UTC
How much RAM is in your system? The minimum for installation of Red Hat Linux 8
is 64M.

Comment 2 Ryan Djurovich 2002-11-12 05:42:26 UTC
I have got 64M, but could it be that the type of RAM is to slow?

Comment 3 case1984 2002-12-28 20:02:38 UTC
I'm getting the exact same error message about 90% of the time I try to 
install red hat 8 on my Intel Pentium 200 mmx w/ 2gb HD + 64 mb ram.  The 
other 10% it makes it up to installing the zip library files (about the ninth 
installed file), then fails.

Comment 4 case1984 2002-12-29 03:25:46 UTC
I just finished installing Red Hat 8.0!
I couldn't get it to work, but as soon as I allocated 128 mb as a swap 
partition instead of 64 or 65 mb, it worked!
It had failed either right after the installer, or during installation itself 
at least 20 times, but as soon as I switched the swap, it worked the first 
time.  It may not work for you, but it worked for me!

Comment 5 Michael Fulbright 2003-01-03 02:55:48 UTC
Did using more swap work for you?

Comment 6 case1984 2003-01-03 08:44:58 UTC
Yes, allocating 128mb instead of 64mb to swap worked the first time!  Maybe 
you could change the documentation to suggest 128mb of swap even if the 
computer has 64mb of memory.
case1984@cox.net

Comment 7 Michael Lee Yohe 2003-01-09 14:05:04 UTC
This appears to be a duplicate of Bug 76123.  The problem is that there is not
enough memory to process the transactions that are to be executed by the
installer.  Anaconda, in GUI mode, requires at least 64M+ of memory and 128M of
swap.  

You can alternatively attempt to install Red Hat Linux 8.0 in text mode by
specifying "linux text" at the SYSLINUX prompt upon first boot.  Anaconda, in
text mode, is more lenient on memory resources.

Comment 8 Jeremy Katz 2003-02-07 20:47:43 UTC

*** This bug has been marked as a duplicate of 76123 ***

Comment 9 Red Hat Bugzilla 2006-02-21 18:50:07 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.