Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77590 - Internal compiler error in tree_low_cst, at tree.c:4325
Summary: Internal compiler error in tree_low_cst, at tree.c:4325
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc
Version: 7.1
Hardware: other
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-09 22:02 UTC by Kim Woodle
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-03 10:33:04 UTC


Attachments (Terms of Use)
C++ source (deleted)
2002-11-09 22:07 UTC, Kim Woodle
no flags Details

Description Kim Woodle 2002-11-09 22:02:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en]C-CCK-MCD MS4.76 V20001206.2  (Win98; U)

Description of problem:
When compiling my code, I get the message
In file included from NvpEstim.C:14:
NvpEstim.H:137: Internal compiler error in tree_low_cst, at tree.c:4325

Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
gmake: *** [../build/ia32.linux.2.4.lib6/gcc296/cc-g/NvpEstim.o] Error 1

also
line NvpEstim.H:137 is the closing bracket }; at the end of a class definition
ID_EXEC=ia32.linux.2.4.lib6
gcc 2.96
Using Rogue Wave Source Pro 3.1


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.gmake install
2.
3.
	

Actual Results:  internal compiler error descibed above

Expected Results:  compilation of source code succeeds on SUN platform

Additional info:

Comment 1 Kim Woodle 2002-11-09 22:07:06 UTC
Created attachment 84364 [details]
C++ source

Comment 2 Jakub Jelinek 2002-11-09 22:37:14 UTC
This looks like http://gcc.gnu.org/ml/gcc-patches/2002-04/msg00738.html
Below is a quick backport of the patch, no testing other than it compiles
and fixes something similar to what I see in your header.
begin 644 gcc296-c++-big-struct.patch.bz2
M0EIH.3%!629362&37VL``F;?@'@P2?______W_J____Z8`9_>5G:W.LD0D``
M:`&(BCU&E/%-IDS4TF:AXIZGJ-I#Q1IIM0/TIZFCU&@;4`:IZGJGJ,AD`3$P
M``(8:3$8`````YHT:&F$`TP)IH`R&AB`-&(T,$9`!ID4TD](T:&@-`:`````
M```T&@YHT:&F$`TP)IH`R&AB`-&(T,$9`!(B$!&@)HI^(BCTS4T(:/2!IH`]
M09E-/49'I*%@;33$&YD"!ZVGLB(D)38HDB'*;!.@4DXMAS]V:90+%8/6!/P*
MW78\T7>U."0L,P/Y#O(#JTGDTD4G--B!>'.(H(&0,?2D-,32I"G3)E6!U?!F
M16%6R0JH%<-!`D+ITY\PE@YD""`06(`OV`4B019]<R*5523I`E)PE01!Q!Q4
MZ^'6A^1.S%V[-(;I,4J6=87B!ZZ="H<,$E5)@^&5\#MD!W&31H&EKU+ODR)X
M[2G"XC4D=-5U+G4P#@B#XG)I`P1NV%72<Q,**>*#4P'ANR(%-,(.B7`.>#R!
MF,\U(.@ID_L:*X-?Z?5J)YEDD$U[(GLJH&*+DLU"%R"8,D`EB0$!LR9='BB2
M2K"B2I?-A=HLNT-FWIDO*J)6-Z(NU#D@(Q'!T-9Q@SW3"V[5+S"*YE,AI@U^
M$K-*X+'.-S6KH\L<JWK#7;PM5UTVNUSAE;9<\IXZPU9T)6#UJ5F8$5[JYOU5
MN^;#D\,B`%]+$EXW"O^7Q*77HJ2,>#(Q$)(H3NZ+NTC/$)Y0L7*H8L"151=(
M-_T178@(/*$':H4$@,6.(QY1J;D@;-K@L&01LWZ5V)ALW[65N7Q0@F@DU<@V
MQCS,'&]+V,#@-PU]]6>%.79BQ73FO&P0)Q,-2!@(8CA%,3#(6.SX<#C\U.Y]
MKY"B$>FS1[N=L%OW7^K+49.Y9,AE@QU7S[ZAUNI<C0C/)MML;<Y/J6MWR(F;
MT30J0@(,M=`IBM&E3$!S8^+N2K5;0N6YA4,ZY$)YA`<D!%VSHXG_3BDG15@9
M4;R).!;EJT`EN,E`\Z.XCHU`=8$`8:Z'!\Z%!8,$-2\BSB0B=Q/X0HQ`N2PB
M1"/K&@K;W>L]N**&_[3@C8*3,O00EF:A%ZP#6&]&DE#8/[$2?\0,SH/W&T^Z
M4F)7^Q&*-H&>N^]+0=`HN!K\Z7K6FS)\!B6-%H\4U#('=1*'QBQ)F8(9BDJ"
M.GKJC/`^[?J<56RB4`,MA,PV?`#9M)RD-MB'\N9@>IS)P!"FQ<0);@`^YNMR
MPZG==K++,NRK_`71,P$@&KMZ`AF^U>7]K>G`00+*1AN,.BE0N'SY:Z%^I@;"
M_:UHF![1R)CF!OT)GM]BJB3_;+Z_H/<&R-`FP^\+%U-)Q)7!_IU0^6<GITBI
M>9(P-^$'8.4PE>'R:UM5_L5LPO</+;GPI&[9(H:XM@QC7?W/;]XV@TY_!L/,
M77W3_;I&W*ZODO[J8&-+,K$WY5Q=!D78F&Z9<.9B9F0&N,FLHJ/9C`C$L!"O
MKJ*8(S0O>[*?-=FSD/_MVXXJAKQW+MW^.]+:+BPO:O#/12O*QO6T+B#->_\C
MTZM,;#2"$ENFPTE5>0FR\(1KE(YF3T6RQ"%YWZ7+KZ)PZW]SH#*J@8IMKPNL
M6\];Y\DX([PNS.;,PZ"5%B/4S@H.OER1>`+Q/!>_Q.4]F7<=S/B8'%@=+)'P
M>?>+OP\%S*&_%*-;A\R)Y&<7VPML*5!U[*VI!$'3\)#)*78GJBUD6PSA7)T)
M4(H45I0RP7]?G9S&ZH[-%B++1;Y4@=RW8/77=$2&".77M@K0T_`JEOE`[;O-
MN.Q'(>OCH;]V%V0*^\Y?&$VY^@('A(6J9AO>ZE)SR#]]R"G*[`EYAW`G#-)@
M[E*F"S1:B"8),$L7#.2BQ9*=USN22[4DQ4[5?<&26IA@.!B&UX2C+\5T!TAN
M@LC!B(H<B<77^)^-078#U6:Q'Q"RQJG7C-G.^8M6IF6C;K!6:5T3?@K4,L+)
MI08N*T'/4:%56BM3@2!X#-[,T.UR!HDT$NP.=;-!N$OB*W7(R^/]WWU.IM-2
MU)CHP].54#V\E4WE3D&[U5%D!)5LD#[+MN[@\6H^%E4#!=@`N7T=YE,'_Q=R
(13A0D"&37VL`
`
end

Comment 3 Richard Henderson 2004-10-03 10:33:04 UTC
The provided test case does appear to be a large struct issue.
And Jakub's patch is in current releases.


Note You need to log in before you can comment on or make changes to this bug.