Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77583 - The hardware browser window crashes after about one second
Summary: The hardware browser window crashes after about one second
Keywords:
Status: CLOSED DUPLICATE of bug 74956
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: hwbrowser
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-09 20:11 UTC by Brian L Scipioni
Modified: 2013-04-02 04:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:07 UTC


Attachments (Terms of Use)

Description Brian L Scipioni 2002-11-09 20:11:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
After selecting the hardware browser: the "searching for hardware" window
breifly appears as is mormal.  Then the harware browser window opens for about 1
second and then disappears.  I see no error messages.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Select Hadware Browser from the GNOME menu.
2.
3.
	

Actual Results:  As above, the window briefly appears then disappears.

Expected Results:  Window should stay open and let me browse hardware.

Additional info:

Comment 1 Jonathan Blandford 2002-11-10 13:56:45 UTC
Can you run it from a shell and paste any tracebacks it puts out?

Comment 2 Brent Fox 2003-01-08 16:17:14 UTC
ping?

Comment 3 Brent Fox 2003-01-21 06:24:52 UTC
Closing due to lack of information.

Comment 4 Steven E Eisele 2003-03-07 03:05:36 UTC
I'm having the exact same problem with both KDE and Gnome...

>>Can you run it from a shell

does this mean command line or terminal?

>>and paste any tracebacks it puts out?

is this the information that scrolls by when using command/terminal modes?

Comment 5 Brian L Scipioni 2003-03-07 12:05:16 UTC
Sorry it took so long to follow up.
The Python script appears to fail on both my 8.0 SMP systems.
When run from the command line:

[brian@radium brian]$ hwbrowser

(DeviceList.py:14420): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: li
ne 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:14420): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: li
ne 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:14420): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: li
ne 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:14420): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: li
ne 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:14420): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: li
ne 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:14420): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: li
ne 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:14420): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: li
ne 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:14420): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: li
ne 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:14420): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: li
ne 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:14420): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: li
ne 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:14420): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: li
ne 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed
Traceback (most recent call last):
  File "/usr/share/hwbrowser/DeviceList.py", line 203, in ?
    reread_device_type_list ()
  File "/usr/share/hwbrowser/DeviceList.py", line 150, in reread_device_type_lis
t
    list.set (iter, 0, hardware.get_category_string (key), 1, key)
  File "/usr/share/hwbrowser/DeviceList.py", line 91, in get_category_string
    return self.type_mapping[key]
KeyError: 20

Comment 6 Brent Fox 2003-03-18 19:14:20 UTC

*** This bug has been marked as a duplicate of 74956 ***

Comment 7 Red Hat Bugzilla 2006-02-21 18:50:07 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.