Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77580 - can't compile gcc 3 sources
Summary: can't compile gcc 3 sources
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 8.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-09 17:24 UTC by Brett Boren
Modified: 2016-11-24 15:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-20 04:59:30 UTC


Attachments (Terms of Use)
config.log (deleted)
2002-11-12 00:46 UTC, Brett Boren
no flags Details
config.status (deleted)
2002-11-12 00:46 UTC, Brett Boren
no flags Details

Description Brett Boren 2002-11-09 17:24:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021018

Description of problem:
Can't compile gcc 3 sources with c++ enabled - seems to be a header problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. D/l gcc sources from gnu.org
2. unpack and run configure with --enable-languages=c,c++
3. begin compile with `make`
	

Actual Results:  while Building stdc++ gives this error:

/home/bab/work/gcc-3.2/build/gcc/xgcc -shared-libgcc
-B/home/bab/work/gcc-3.2/build/gcc/ -nostdinc++
-L/home/bab/work/gcc-3.2/build/i686-pc-linux-gnu/libstdc++-v3/src
-L/home/bab/work/gcc-3.2/build/i686-pc-linux-gnu/libstdc++-v3/src/.libs
-B/opt/gcc-3.2/i686-pc-linux-gnu/bin/ -B/opt/gcc-3.2/i686-pc-linux-gnu/lib/
-isystem /opt/gcc-3.2/i686-pc-linux-gnu/include -nostdinc++
-I/home/bab/work/gcc-3.2/build/i686-pc-linux-gnu/libstdc++-v3/include/i686-pc-linux-gnu
-I/home/bab/work/gcc-3.2/build/i686-pc-linux-gnu/libstdc++-v3/include
-I../../../../libstdc++-v3/libsupc++ -I../../../../libstdc++-v3/libmath -g -O2
-D_GNU_SOURCE -fno-implicit-templates -Wall -Wno-format -W -Wwrite-strings
-Winline -fdiagnostics-show-location=once -ffunction-sections -fdata-sections -g
-c c++locale.cc  -fPIC -DPIC -o
.libs/c++locale.o
c++locale.cc: In function `void std::__convert_to_v(const char*, _Tv&,
   std::_Ios_Iostate&, __locale_struct* const&, int) [with _Tv = long int]':
c++locale.cc:51: `__strtol_l' undeclared (first use this function)
c++locale.cc:51: (Each undeclared identifier is reported only once for each
   function it appears in.)
c++locale.cc: In function `void std::__convert_to_v(const char*, _Tv&,
   std::_Ios_Iostate&, __locale_struct* const&, int) [with _Tv = long unsigned
   int]':
c++locale.cc:69: `__strtoul_l' undeclared (first use this function)
c++locale.cc: In function `void std::__convert_to_v(const char*, _Tv&,
   std::_Ios_Iostate&, __locale_struct* const&, int) [with _Tv = long long
   int]':
c++locale.cc:87: `__strtoll_l' undeclared (first use this function)
c++locale.cc: In function `void std::__convert_to_v(const char*, _Tv&,
   std::_Ios_Iostate&, __locale_struct* const&, int) [with _Tv = long long
   unsigned int]':
c++locale.cc:106: `__strtoull_l' undeclared (first use this function)
c++locale.cc: In function `void std::__convert_to_v(const char*, _Tv&,
   std::_Ios_Iostate&, __locale_struct* const&, int) [with _Tv = float]':
c++locale.cc:124: `__strtof_l' undeclared (first use this function)
c++locale.cc: In function `void std::__convert_to_v(const char*, _Tv&,
   std::_Ios_Iostate&, __locale_struct* const&, int) [with _Tv = double]':
c++locale.cc:141: `__strtod_l' undeclared (first use this function)
c++locale.cc: In function `void std::__convert_to_v(const char*, _Tv&,
   std::_Ios_Iostate&, __locale_struct* const&, int) [with _Tv = long double]':
c++locale.cc:158: `__strtold_l' undeclared (first use this function)
c++locale.cc: In static member function `static void
   std::locale::facet::_S_create_c_locale(__locale_struct*&, const char*,
   __locale_struct*)':
c++locale.cc:170: `__newlocale' undeclared (first use this function)
c++locale.cc: In static member function `static void
   std::locale::facet::_S_destroy_c_locale(__locale_struct*&)':
c++locale.cc:180: `__freelocale' undeclared (first use this function)
c++locale.cc: In static member function `static __locale_struct*
   std::locale::facet::_S_clone_c_locale(__locale_struct*&)':
c++locale.cc:184: `__duplocale' undeclared (first use this function)
make[3]: *** [c++locale.lo] Error 1
make[3]: Leaving directory
`/home/bab/work/gcc-3.2/build/i686-pc-linux-gnu/libstdc++-v3/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
`/home/bab/work/gcc-3.2/build/i686-pc-linux-gnu/libstdc++-v3'
make[1]: *** [all-recursive-am] Error 2
make[1]: Leaving directory
`/home/bab/work/gcc-3.2/build/i686-pc-linux-gnu/libstdc++-v3'
make: *** [all-target-libstdc++-v3] Error 2


Expected Results:  should have built

Additional info:

Comment 1 Jakub Jelinek 2002-11-09 17:55:15 UTC
The problem is actually that you don't have de_DE locale installed.
gcc rpms in rawhide build the locale on the fly if not installed.

Comment 2 Brett Boren 2002-11-09 18:57:05 UTC
No, I followed the commands you gave for the other bug about gcc not compiling.
Hence, these were the commands I issued:

localedef -f ISO-8859-1 -i de_DE /var/tmp/de_DE

export LOCPATH=/var/tmp:/usr/lib/locale

configure and then make.

Comment 3 Jakub Jelinek 2002-11-09 19:51:49 UTC
Can you attach /home/bab/work/gcc-3.2/build/i686-pc-linux-gnu/libstdc++-v3/config.{status,log}?
Do you have at least glibc and its headers 2.2.93 installed?
Does rpm in rawhide work for you?

Comment 4 Brett Boren 2002-11-12 00:46:35 UTC
Created attachment 84589 [details]
config.log

Comment 5 Brett Boren 2002-11-12 00:46:55 UTC
Created attachment 84590 [details]
config.status

Comment 6 Brett Boren 2002-11-12 00:47:52 UTC
How do I get to rawhide?



Comment 7 Jakub Jelinek 2002-11-13 21:43:47 UTC
And are you building it against glibc-2.2.93+ headers?
As for rawhide, you can find it on any Red Hat mirror, in pub/redhat/linux/rawhide/

Comment 8 Brett Boren 2002-11-15 14:23:39 UTC
I'm building against the standards headers with 8.0

I'm having difficulty pulling the glibc rpms from rawhide. One day they're
there, the next day they're gone. When can I count on them being there?



Comment 9 Brett Boren 2002-11-20 04:58:32 UTC
Ok, glibc-2.3.1-6 rpm's installed... still doesn't fix the problem...

However, I just pulled down gcc-3.2.1 and it compiles fine

Must have been a gcc problem?


Note You need to log in before you can comment on or make changes to this bug.