Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77568 - TB ipcalc.py:60:network
Summary: TB ipcalc.py:60:network
Keywords:
Status: CLOSED DUPLICATE of bug 76267
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-09 12:10 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-09 12:10:42 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-09 12:10:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 
1.0.3705)

Description of problem:
The RedHat Network Config tool crashes when trying to save, and, most settings 
aren't saved.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Point 'Start Here'
2. Point 'System Settings'
3. Point 'Network Configuration'
4. Change something.
5. Save
6. Exception Occured
	

Actual Results:  Received an Exception Occurred. See Additional Information for 
the dump. And the 'saved' settings weren't saved.

Expected Results:  The settings should've been saved.

Additional info:

Traceback (most recent call last):
  File "/usr/sbin/neat", line 496, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 319, in save
    self.saveDevices()
  File "/usr/sbin/neat", line 326, in saveDevices
    devicelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCDeviceList.py", 
line 145, in save
    os.write(fp2, ipc.network()+'/'+ipc.prefix()+" via "+route.Gateway+"\n")
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ipcalc.py", line 
60, in network
    return re.match("NETWORK=(\S+)", text).groups()[0]
AttributeError: 'NoneType' object has no attribute 'groups'

Local variables in innermost frame:
text: 
self: <netconfpkg.ipcalc.IPCalc instance at 0x84a0cd4>

Comment 1 Harald Hoyer 2002-11-11 10:00:17 UTC

*** This bug has been marked as a duplicate of 76267 ***


Note You need to log in before you can comment on or make changes to this bug.