Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77549 - System freeze with kernel-RH-2.4.18-x
Summary: System freeze with kernel-RH-2.4.18-x
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: athlon
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-08 21:05 UTC by Féliciano Matias
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-11 04:26:22 UTC


Attachments (Terms of Use)

Description Féliciano Matias 2002-11-08 21:05:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
system freeze randomly. 

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.use xawtv in mode grabdisplay
2.open gvim with a big text file
3.resize the gvim window	

Actual Results:  system freeze. no message via syslogd

Additional info:

Sorry for my poor english.
This bug append randomly. It can append in normal use. It append frequently
under intensive use of x11 and also when copying a lot of files between two disks.
I do several tests :
kernel-RH : 2.4.18-14 => freeze
kernel-RH : 2.4.18-17.8.0 => freeze
kernel-RH : 2.4.18-17.8.0custom (feet my needs) gcc-3.2 => freeze
kernel-RH : 2.4.18-17.8.0custom gcc-2.96 => freeze
kernel-RH : 2.4.18-17.7.xcustom gcc-2.96 => freeze
kernel : 2.4.20-rc1 : ok but i get sometime something like "/dev/hde fifo 0
byte" followed by a freeze
kernel-RH-rawhide (old) : 2.4.17-0.1custom gcc-2.96 : ok

my hardware (no overclocking):
$ cat /proc/cpuinfo
processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 6
model		: 6
model name	: AMD Athlon(tm) XP 1600+
stepping	: 2
cpu MHz		: 1405.065
cache size	: 256 KB
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36
mmx fxsr sse syscall mmxext 3dnowext 3dnow
bogomips	: 2804.94

$ lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8367 [KT266]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8367 [KT333 AGP]
00:05.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 06)
00:06.0 Multimedia controller: Sigma Designs, Inc. REALmagic Hollywood Plus DVD
Decoder (rev 02)
00:07.0 Unknown mass storage controller: Triones Technologies, Inc.
HPT366/368/370/370A/372 (rev 03)
00:08.0 ATM network controller: SGS Thomson Microelectronics: Unknown device
0500 (rev 10)
00:09.0 Multimedia video controller: Brooktree Corporation Bt848 Video Capture
(rev 12)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8233 PCI to ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586B PIPC Bus Master IDE (rev 06)
01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage IIC AGP (rev 7a)

Comment 1 Féliciano Matias 2002-11-09 20:47:57 UTC
With kernel-2.4.18-x i also have some troubles with the keyboard in X11. Indeed,
the automatic repeat of the keys is sometimes really excessive. This is
particuliairement remarkable with multi-gnome-terminal when i presse the keys
[sift]+[->] or [<-] to switch between terminals.

Comment 2 Féliciano Matias 2002-11-15 13:08:04 UTC
I have swaped the disks between my two ide cards.

before :

VP_IDE: VIA vt8233:
hda: WDC WD205AA-00BAA0, ATA DISK drive
hdc: SAMSUNG CD-R/RW SW-240B, ATAPI CD/DVD-ROM drive
hdd: CREATIVE DVD-ROM DVD1243E, ATAPI CD/DVD-ROM drive
HPT370:
hde: Maxtor 90340D2, ATA DISK drive
hdg: Maxtor 90340D2, ATA DISK drive

now :

VP_IDE: VIA vt8233:
hda: Maxtor 90340D2, ATA DISK drive
hdc: Maxtor 90340D2, ATA DISK drive
HPT370:
hde: SAMSUNG CD-R/RW SW-240B, ATAPI CD/DVD-ROM drive
hdf: CREATIVE DVD-ROM DVD1243E, ATAPI CD/DVD-ROM drive
hdg: WDC WD205AA-00BAA0, ATA DISK drive

This solve my problem when copying file between two disks.

I do some tests with kernel linux-RH-2.4.19-0.pp.9 and linux-2.4.20-rc1-ac1. I
have less ofen freeze. linux-2.4.20-rc1-ac1 is more reliable. However, i can not
mount cdrom, and it spend two more cpu usage when i play avi file with mplayer.

Currently only kernel-RH-2.4.17-0.1 can be use "safety" with my computer. With
others kernels i can't get an uptime greater than 2 hours.

Comment 3 Féliciano Matias 2002-11-18 02:18:11 UTC
Sorry for my poor english.

good news : Every things is OK now.

It seems i have some problems with the IDE controler VT82C586B when DMA is
enabled (which is the default. Even with CONFIG_IDEDMA_NEW_DRIVE_LISTING.) and i
use xawtv (card : Bt848) in same time. As recommended by some README in bttv, i
have changed the latency of the card but that don't fixe my freeze problems. I
also tested with the lastest stable release of bttv (0.7.100) without success.

The linux-RH-2.4.17 has this problem also, but it appeard seldom.

I encountered this problem with all my hard disks. I don't do any test with
cdrom. For me this is a very high problem. I experiment two massive filesystem
corruption (with ext3 and error behavior set to remount-ro).

I try to test linux-2.5.47. The bttv modules can't be build. I grab the version
0.9.1 from the bttv site and build modules out of the linux tree.

But when i try to read files from disks connected to the IDE controler VT82C586B
(with or without DMA enabled) i get after less than 2 seconds :
kernel BUG at drivers/block/ll_rw_blk.c:1910!
kernel: invalid operand: 0000
kernel: bttv video-buf i2c-algo-bit i2c-core videodev v4l2-common soundcore
dummy0 af_packet ide-cd cdrom rtc unix
kernel: CPU:    0
kernel: EIP:    0060:[<c01a63d7>]    Not tainted
kernel: EFLAGS: 00010246
kernel: eax: 00000000   ebx: 00000000   ecx: 00000000   edx: cf606f00
kernel: esi: cf606f00   edi: 00000001   ebp: 00000001   esp: ca26fc0c
kernel: ds: 0068   es: 0068   ss: 0068
kernel: Process mv (pid: 752, threadinfo=ca26e000 task=ca86b340)
kernel: Stack: c12b8e00 cf606f00 c015a9de 00000000 cf606f00 00001000 c015abea
00000000
kernel:        cf606f00 00001000 00000000 cff5aa80 c1377340 000001cc 00000001
0000000c
kernel:        ca2190bc 00000010 00000000 00000000 cfc81d40 000a82cf cff5aa80
cfaca300
kernel: Call Trace: [<c015a9de>]  [<c015abea>]  [<c01402df>]  [<c015ae6f>] 
[<c016dba0>]  [<c0132eff>]  [<c0138769>]  [<c016dba0>]  [<c0133212>] 
[<c013881f>]  [<c01388e4>]  [<c012b8d0>]  [<c012bbf0>]  [<c012be8a>] 
[<c012bbf0>]  [<c012bf2a>]  [<c013eb4c>]  [<c013ec5a>]  [<c013eefe>]  [<c01090a3>]
kernel: Code: 0f 0b 76 07 6c 16 23 c0 eb aa 90 8d b4 26 00 00 00 00 8d bc

The files are readed from a raid 0 software partition.

Note that linux-2.5.47 (like 2.4.x) also enable DMA by default for the IDE
controler VT82C586B. 

I don't have any problems with the IDE controler HPT370 with DMA enabled (which
is not the default for this controler) and i can play safety with hdparm with
this controler.

I use alsa and alsa version 0.9.0rc5 can freeze my system sometimes (strangly
there is no problem with linux 2.4.17). An update to version 0.9.0rc6 fixe this
problem.

I have said earlier that linux-2.4.20-rc1-ac1 spend two more cpu usage when i
play avi file with mplayer. It is wrong. Perhaps i forget to compile mtrr support.

With kernel-RH-2.4.18-18 i still have some problems with keyboard under X.

Currently i use kernel-RH-2.4.19-0.pp.15 (this kernel don't suffer of the
keyboard problem).

conclusion :
Don't enable DMA with the IDE controler VT82C586B when bttv is used.
alsa version 0.9.0rc5 can freeze the system. version 0.9.0rc6 is fine.
kernel-RH-2.4.18-18.8.0 still have some problem with keyboard under X.

Comment 4 Féliciano Matias 2002-12-07 19:01:19 UTC
I update my bios and the problem is solved (bios v3.3 to v3.7). I can now enable
DMA with the IDE controler VT82C586B and use bttv at the same time without
freezing my computer.

Product specification :
http://www.msi.com.tw/program/products/mainboard/mbd/pro_mbd_detail.php?UID=29&MODEL=MS-6380
Bios upgrade :
http://www.msi.com.tw/program/support/bios/bos/spt_bos_detail.php?UID=28&NAME=MS-6380%20Ver2.0

I always have some trouble with keyboard under X11.

Can someone close this bug?

Comment 5 Féliciano Matias 2002-12-10 14:08:25 UTC
I am really sorry.
I always have this problem.
After bios update my uptime was 15 days and with intensive stress of disks with
DMA enabled.
Lastly i rebooted my system and now my system freeze quickly (around 3 min) when
i use disks pluged into the IDE controler VT82C586B with DMA enables.

This make me crazy.

Comment 6 Féliciano Matias 2003-01-11 04:26:22 UTC
I slow down the transfert mode of Maxtor 90340D2 disks :
hdparm -X mdma0

The defaut setting is mdma2. No freeze since 3/4 weeks.


Note You need to log in before you can comment on or make changes to this bug.