Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77545 - When using a kvm switch the mouse stops working.
Summary: When using a kvm switch the mouse stops working.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gpm
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-08 20:28 UTC by Glen
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-07-16 17:17:15 UTC


Attachments (Terms of Use)

Description Glen 2002-11-08 20:28:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
The mouse stops working sometimes on computers hooked up to a kvm switch.  This
happens with both the Belkin Omni View SE 4 port kvm switch and the Belkin Omni
View Pro 16 port kvm switch.  At first the mouse is fine, but after switching
around to different computers it will stop working.  The cursor will move to the
top right corner and stay there when you move the mouse.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Hook your redhat 7.3 computers up to a Belkin kvm switch.
2. Switch computers using the kvm switch.


Actual Results:  The mouse goes to the top right corner.

Additional info:

Comment 1 John Martin 2003-02-17 16:20:53 UTC
I have recently added an Iogear KVM switch. My XP system works O.K, but my
RedHat 8 system has a problem with the mouse. The mouse will not work in X or
gpm. This seems to be the same problem described in bug 77545. I have more info
for this bug. I have tried several different mice. Both two button and three
button. No wheel mouse tried.

I have tried the following Linux versions.

RedHat 8, with the default Kernel and latest Kernel:
gpm sees no mouse, XFree86 sees no mouse. Boot messages indicate PS/2 mouse
found, but mouse movements and keys are not recognized.

RedHat 7.2
gpm sees no mouse, XFree86 sees no mouse. Boot messages indicate PS/2 mouse
found, but mouse movements and keys are not recognized.

RedHat 6, Kernel 2.2.5-15
gpm- mouse works, XFree86- mouse works.

All Linux run on same hardware, just different hard drives.

Looks like updates to mouse support in 7.x Kernel removed support for KVM switches. 

Comment 2 Quande Ren 2003-07-15 15:30:37 UTC
I have a DELKIN 4-port KVM switch. it works perfect with Red had linux 6.1. 
It's mouse functions cann't work well with Red had linux 9, The monitor and the 
keyboard are working OK,

when running with Red had linux 9, I switch to other computer, and switch back 
again, the linux get confused with the moving event and left click event. the 
right click event is working OK. 

If I restart the linux, and never switch, then it is working ok.

Comment 3 John Martin 2003-07-16 02:18:39 UTC
I upgraded to RedHat 9 and now my KVM switch works as expected.


Note You need to log in before you can comment on or make changes to this bug.