Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77535 - Tab completion inserts spaces after directories
Summary: Tab completion inserts spaces after directories
Keywords:
Status: CLOSED DUPLICATE of bug 72512
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash
Version: 8.0
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-08 17:49 UTC by Derek Price
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-08 17:54:06 UTC


Attachments (Terms of Use)

Description Derek Price 2002-11-08 17:49:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
Bash tab completion now inserts spaces after tab completing the name of a
directory rather than inserting a / and allowing for the completion of the next
portion of the path.  This makes it harder to use tab completion for completion
of long path names.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Pick a directory under the current.
2. Type `vi <c><tab>' where <c> is some number of characters which can specifiy
the directory uniquely within the list of directories under the current, and
<tab> is a real TAB character.
	

Actual Results:  Bash turns the command line into the following:

$ vi <directory name><space><cursor>

Expected Results:  $ vi <directory name>/<cursor>

Additional info:

Comment 1 Tim Waugh 2002-11-08 17:57:31 UTC

*** This bug has been marked as a duplicate of 72512 ***


Note You need to log in before you can comment on or make changes to this bug.