Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77523 - 2.4.18-17.7.x fails to compile when CONFIG_MODVERSIONS=y
Summary: 2.4.18-17.7.x fails to compile when CONFIG_MODVERSIONS=y
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-08 14:55 UTC by Peter Collinson
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-08 15:39:31 UTC


Attachments (Terms of Use)

Description Peter Collinson 2002-11-08 14:55:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Win98; U)

Description of problem:
The kernel build fails when making modules. It seems that the file:
include/linux/modules/ksyms.ver is saying:

#define loops_per_jiffy _set_ver(loops_per_jiffy)

and loops_per_jiffy is a member of a structure 
	struct cpuinfo_x86
that is broken by this definition. The structure entry becomes
        unsigned long loops_per_jiffy_R_ver_str(ba497f13);
which isn't legal.

Since the default for the config program is to enable this flag, it causes great confusion with Linux novices
like me - who really expect that kernels from Redhat should compile..

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start with a fresh kernel and no .config file
2. Run make config and select nothing - simply save the file
3 make clean
4 make dep
5 make bzImage
6 make modules

	

Actual Results:  Compilation dies  - in my case in module - cdrom.c. Sorry I have lost the actual results since I found the workaround
for the problem.

Expected Results:  The kernel should compile.

Additional info:

Comment 1 Arjan van de Ven 2002-11-08 15:39:25 UTC
looks like you forgot make mrproper as first step..

Comment 2 Peter Collinson 2002-11-08 15:51:09 UTC
Yep - thanks for not saying RTFM!



Note You need to log in before you can comment on or make changes to this bug.