Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77505 - display corruption on Chips & Technologies CT65554
Summary: display corruption on Chips & Technologies CT65554
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 8.0
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-08 01:42 UTC by Rick Gaudette
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-22 08:51:46 UTC


Attachments (Terms of Use)

Description Rick Gaudette 2002-11-08 01:42:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Just about any window operation leaves un-updated window regions on the display.
 The most obvious is using a scroll bar which will leave many repeated or grey
regions in the window.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use scroll bar in any window sliding causes more courrption than stepping
2.i.e. terminals (all), mozilla or the redhat system logs app are good examples 
3.	

Actual Results:  display becomes corrupted

Expected Results:  display should not become corrupted

Additional info:

This is on an old HP omnibook Pentium 166 w/ 32 MB of ram if that makes any
difference

Comment 1 Mike A. Harris 2002-11-08 13:13:16 UTC
I'm working on trying to fix some bugs in the chips driver right now
due to the XFree86 driver having some breakage that has been reported.

Unfortunately I don't have any chips hardware, so I need someone who does
have it to do some tests for me so I can fix it.  I also need to see
a screenshot of this corruption if possible.  So first step, is to make
a screenshot and attach it to the bug report using the link below, as
well as your X config file and log file.  I also need the output of
"lspci -vvn" for debugging.

Next step, is to try different troubleshooting tests:

First test, in your XF86Config, put in the Device section:
     Option "noaccel"

If that makes the problem go away, then we know it is a 2D acceleration
bug (most likely).

Next test is to find out exactly what is broken.  To do that, I need you
to read the "man XF86Config" manual, and look for the various "XaaNo....."
options.  Remove the above "noaccel" option from the config file, and try
_one_ of the XaaNo options.  After adding one of them, start the X server
and test to see if the corruption is gone.  If the corruption persists,
quit X, comment out or remove the XaaNo option, and replace it with
another XaaNo option.  Continue through the list until you've tried
every option.  If any one option solves the problem, indicate what option
it is to me, and please attach a new X config file and log from the
server ran with this XaaNo option being used.

If noaccel worked, but no one single option solves the problem for you,
try using multiple XaaNo options, and try to narrow it down.  If you
can narrow it down to one or two options, then I can probably fix the
driver.

Thanks.



Comment 2 Mike A. Harris 2002-12-22 08:51:46 UTC
Reported as working by a user in rawhide XFree86 as of December 17th,
so closing as RAWHIDE.


Note You need to log in before you can comment on or make changes to this bug.