Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7750 - does not keep proper time on laptop
Summary: does not keep proper time on laptop
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-11 08:22 UTC by SI Reasoning
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-25 02:56:52 UTC


Attachments (Terms of Use)

Description SI Reasoning 1999-12-11 08:22:44 UTC
After upgrading to Redhat 6.1 from 6.0, I started noticing that the time
kept slipping. When it reboots, the time is correct but it starts losing
seconds immediately.... to the point where it can lose an hour or so a day.
I have all of the updates, including gnome, and I am running the newest
enlightenment. I also use vmware with Linux as host. I am not exactly
certain when this problem occurred but I suspect that 1 of the 3 (upgrade,
vmware, new enlightenment) may be the culprit.

I also guessed at the file "time" as the one causing the problem.

Comment 1 Jeff Johnson 2000-08-16 17:18:25 UTC
Losing time is most likely a kernel problem, changing component

Comment 2 SI Reasoning 2000-09-01 17:01:24 UTC
I have since changed laptops (upgraded to an updated model) and still have the
same problem. I went from a Chembook 7400 to a 7400-B (Asus F-7400 to F-7400B).

Comment 3 Doug Ledford 2000-09-02 02:07:08 UTC
This could be caused by the laptop loosing time while it is suspended.  Does the
time loss happen all at once or can you actually watch it happen while the
system is in use?

Comment 4 SI Reasoning 2000-09-02 03:02:31 UTC
You can watch it happen.... It loses time every minute...but nothing consistant
that can be adjusted... at least the last time I tried months ago. I currently
update my time through ntpdate cron every hour. I used to do it every minute
since the loss was so bad.

Comment 5 SI Reasoning 2000-09-02 08:39:44 UTC
Here are 8 hours worth of ntpdate updates:

1 Sep 20:01:47 ntpdate[5927]: step time server 130.126.24.24 offset 106.667959
sec
1 Sep 21:01:48 ntpdate[6198]: step time server 130.126.24.24 offset 106.906458
sec
1 Sep 22:01:48 ntpdate[6505]: step time server 130.126.24.24 offset 107.019308
sec
1 Sep 23:01:48 ntpdate[6855]: step time server 130.126.24.24 offset 106.444481
sec
2 Sep 00:01:47 ntpdate[7137]: step time server 130.126.24.24 offset 105.636691
sec
2 Sep 01:01:46 ntpdate[7421]: step time server 130.126.24.24 offset 105.362106
sec
2 Sep 02:01:55 ntpdate[7738]: step time server 130.126.24.24 offset 113.298043
sec
2 Sep 03:01:47 ntpdate[8009]: step time server 130.126.24.24 offset 105.456529
sec


Comment 6 Stephen John Smoogen 2003-01-25 02:56:52 UTC
From what I remember, most of these issues listed above were related to VMWARE
module and time in the 2.2. kernel.  It was something dealing with APM, VMWARE,
and other 2.2 issues. The problem might be fixed in later VMWARE issues, but it
is not a Red Hat problem but a closed source module problem.


Note You need to log in before you can comment on or make changes to this bug.