Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77491 - ttmkfdir returns SIGABRT and produces only an "Aborted" message when encountering a corrupted font file
Summary: ttmkfdir returns SIGABRT and produces only an "Aborted" message when encounte...
Keywords:
Status: CLOSED DUPLICATE of bug 77272
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-07 22:09 UTC by Michael Lee Yohe
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-09 21:18:26 UTC


Attachments (Terms of Use)
Sewer font - usable by Windows, not by ttmkfdir (deleted)
2002-11-07 22:10 UTC, Michael Lee Yohe
no flags Details

Description Michael Lee Yohe 2002-11-07 22:09:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
ttmkfdir is apart of the XFree86-font-utils package.

When ttmkfdir is run in a directory that contains a bad true type font file, it
will produce only "Aborted" and return SIGABRT.  No error description is given.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download the sewer.ttf attachment and place it in a directory by itself.
2. Go to the directory.
3. Run "ttmkfdir"
	

Actual Results:  Aborted

Expected Results:  "sewer.ttf" is corrupted - please remove this font before
proceeding.

**OR**

Ignoring corrupted font "sewer.ttf"

Additional info:

XFree86-font-utils-4.2.0-72

Comment 1 Michael Lee Yohe 2002-11-07 22:10:16 UTC
Created attachment 84064 [details]
Sewer font - usable by Windows, not by ttmkfdir

Comment 2 Gene Czarcinski 2002-11-09 21:18:19 UTC
This is a dup of <a HREF="show_bug.cgi?id=77272">Bug 77272</a>

Comment 3 Michael Lee Yohe 2002-11-09 22:28:02 UTC
Confirming that it's a duplicate.

*** This bug has been marked as a duplicate of 77272 ***

Comment 4 Yu Shao 2002-11-10 03:15:08 UTC
Fot the sewer.ttf, ttmkfdir will skip it:

[root@localhost ttmkfdir2]# ./ttmkfdir
Warning: Can't initialize Face : sewer.ttf(2)
Warning: Can't initialize Face : aaa.ttf(85)
[root@localhost ttmkfdir2]# ftview ppem sewer.ttf
could not find/open any font file
  error = 0x0002
[root@localhost ttmkfdir2]#



Note You need to log in before you can comment on or make changes to this bug.