Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77477 - raid 5 reconstruction "freze" if device is in use
Summary: raid 5 reconstruction "freze" if device is in use
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-07 17:37 UTC by Alain Spineux
Modified: 2008-08-01 16:22 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-30 15:40:10 UTC


Attachments (Terms of Use)

Description Alain Spineux 2002-11-07 17:37:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
When I set a device as failed on a raid 5 that is curently in use (mounted fs) 
using the command : 
# mdadm /dev/md0 -f /dev/hdb1
the command freeze and any mdadm or access to the mounted fs fail

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. mdadm -C -l5 -n3 -x1 /dev/md0 /dev/sdb[1234]
2. mke2fs -j /dev/md0 ; mount /dev/md0 /mnt
3. while sleep 1 ; do date >> /mnt/log ; done &
4. tail -f /mnt/log
5. mdadm /dev/md0 -f /dev/sdb1
	

Actual Results:  the mdamd command never finish and any access to /mnt or mdadm 
command fail !
If /dev/md0 is not in use (no access to the mounted fs) this works
I have to restart the machine and restart/repair/reconstruct the raid device
If the root in on an raid device too, the machine will refuse to restart !

Additional info:

I was making some test/exercise on an rh8.0 to learn mdadm and know what to do 
to replace a failed disk.
I was first making test using /dev/loop? then tried real device /dev/hdb* to 
know if the probleme was about /dev/loop.
The same probleme append with a RH7.3 too: Both (rh73 and rh80) use kernel 
2.4.18.
I tried an an RH72 kernel 2.4.7 and it was working fine.

Comment 1 Bugzilla owner 2004-09-30 15:40:10 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/



Note You need to log in before you can comment on or make changes to this bug.