Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77476 - Installation fails at choice of Workstation, Serve, etc.
Summary: Installation fails at choice of Workstation, Serve, etc.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-07 17:32 UTC by Jonathon M. Robison
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-25 14:59:53 UTC


Attachments (Terms of Use)

Description Jonathon M. Robison 2002-11-07 17:32:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98; F-5.0.1SP1-
20000718; F-5.0.1-20000221)

Description of problem:
We have hundreds of Dell Latitude laptops here, from CPx's to C600s. Of the 8 
of us who have tried to install RH 8.0 so far, ALL have stopped at the point 
where you choose Workstation, Server, etc. When you click "Next", the "Install" 
radio button unchecks, the rest of the menu goes translucently gray, etc. but 
ABSOLUTELY NOTHING happens. You can re-click the "Install" radio button, and 
try again - over and over. You can click "Back" and you go back. But you cannot 
go forward.

I seem to recall having had the same problem with 7.3 and having to use text 
mode.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Buy a Latitude C600, BIOS revs from A06 to A16
2. Insert RH 8.0 CD and begin graphical install
3. Select "Next" after choosing a type of install
	

Actual Results:  "Install" radio button unselects itself, screen menu area goes 
translucently gray. No drive activity, NADA. As if the code is in there to turn 
the screen gray when you click Next, but the code to actually DO something is 
commented out.

Expected Results:  Should have progressed to drive formatting/checking and 
package installation.

Additional info:

Haven't been able to test BIOS rev's beyond A16, but let's face it - how many 
users routinely bother to upgrade BIOS?

Comment 1 Michael Fulbright 2002-11-07 18:15:59 UTC
Have you tried a text mode install?

Type 'linux text' at the boot command line.

Have not had any reports like this for Dells other than sometimes the X server
does not get the resolution we expect.  You can try working around this by
saying 'linux resolution=<res>', where <res> is somthing like '1024x768', and
<res> is the native resolution of your LCD display.



Comment 2 Jonathon M. Robison 2002-11-07 18:30:55 UTC
Yes, I can do text mode installs. That's how I have had to do all of the 
Latitude installs, because of this problem.

The X resultion should not be the problem, since I obviously get to the point 
of choosing install type (Workstation, Server, etc.) all in X.

Considering that there is NO disk activity, the screen does NOT lock up (I can 
go Back, etc.), and that I can jump to console and see that no errors are 
listed, I don't think this is an X issue. It's gotten to the point that every 
day people walk up to my office and ask me how to fix it because they want to 
install Redhat for testing. So far, EVERY Dell Latitude C series laptop that I 
have tried to install 8.0 on (and 7.3, earlier) has done this.

Comment 3 Michael Fulbright 2003-01-03 02:04:17 UTC
Out of curiosity, could you try a Phoebe (our new beta) install on these
machines and let me know if it acts differently?

Comment 4 Jonathon M. Robison 2003-01-03 13:52:35 UTC
Fraid not. These are not my machines, and the two laptops I use myself are 
dedicated to Advanced Server testing.

This can't be new. It used to happen on 7.3 as well. Also, I have had a few 
desktops (Dell OptiPlex GX1 units) who have also reported the exact same 
problem.

In all cases, text mode install went smoothly.

Comment 5 Jeremy Katz 2003-01-10 07:02:24 UTC
This is due to the X server not respecting the resolution we asked it to start
in and so our calculated dpi is incorrect.  We handle this in Phoebe by setting
the dpi differently.  A workaround for Red Hat Linux 8.0 is to boot with 'linux
resolution=1024x768' (replace 1024x768 with the native panel resolution if the
panel uses a different native resolution).

Comment 6 Brent Fox 2003-05-25 14:59:53 UTC
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.


Note You need to log in before you can comment on or make changes to this bug.