Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77471 - 2.4.18-17.7.x causes serial palm to no longer sync
Summary: 2.4.18-17.7.x causes serial palm to no longer sync
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-pilot
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-07 16:22 UTC by James Riggs
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-11-03 12:55:21 UTC


Attachments (Terms of Use)

Description James Riggs 2002-11-07 16:22:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

Description of problem:
Upgraded 7.3 to latest errata kernel 2.4.18-17.7.x.  After upgrade gnome-pilot
will no longer sync with palm connected to serial port 2 /dev/ttyS1. Downgraded
kernel to 2.4.18-10 and gnome-pilot would once again sync.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Upgrade 7.3 to kernel 2.4.18-17.7.x
2.  Attempt to sync palm pilot using serial cradle
3.
	

Actual Results:  gnome-pilot never detects the palm pilot.  Palm will eventually
time out unable to connect.

Expected Results:  Expect palm to sync with gnome-pilot

Additional info:

Comment 1 James Riggs 2002-11-25 18:15:22 UTC
Tested 2.4.18-18.7.x  Still cannot sync serial palm after update.

Comment 2 James Riggs 2003-02-19 14:48:32 UTC
Finally got around to doing some additional testing regarding this problem.  The
bug seems to be gnome-pilot specific.  System is now updated to 2.4.18-24.7.x
kernel.  gnome-pilot is still unable to connect to the palm.  However, I was
able to execute pilot-xfer from the command line and back up all files from the
plam.  pilot-xfer works fine but gnome-pilot will not work unless using
2.4.18-10 or earlier kernel.

Comment 3 James Riggs 2003-02-21 20:13:58 UTC
Did a little more research.  gpilotd seems to be the problem.  I could not
communicate with the palm from the command line using pilot-xfer while gpilotd
was running.  Killed gpilotd and pilot-xfer was able to connect and send and
receive with the palm.

Comment 4 Dave Malcolm 2004-11-02 21:18:09 UTC
I'm sorry that this bug has gone so long without activity.

Did killing gpilotd one time as mentioned in ccomment #3 fix the
problem permanently?

Otherwise: What version of gnome-pilot was this with?  The one that
shipped with Red Hat Linux 7.3? (gnome-pilot-0.1.64, I believe)

Have you had any success with more recent versions of the kernel, or
of gnome-pilot?

Comment 5 James Riggs 2004-11-03 12:55:21 UTC
Actually reported this back when 7.3 was the newest distro.  Have not
seen this for a while so I belive this can be closed as fixed with
newer versions.


Note You need to log in before you can comment on or make changes to this bug.