Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77470 - rhn-applet-gui consumes a large portion of memory for just a resident applet
Summary: rhn-applet-gui consumes a large portion of memory for just a resident applet
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-07 16:09 UTC by Michael Lee Yohe
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:06 UTC


Attachments (Terms of Use)

Description Michael Lee Yohe 2002-11-07 16:09:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
rhn-applet-gui sits in the Gnome panel display a few different icons.  Every
once in a while, it will sit near the top of "top" while it is doing its checking.

 3533 myohe     15   0 16240  15M  9868 S     0.0  2.1   0:21 rhn-applet-gui

16M of memory consumed.  Nautilus does much more (draws the desktop, displays
folders, etc.) and it consumes only a mere 4M more than the applet in just a
normal session.  I suppose it is do to the fact that rhn-applet-gui is a
resident Python session versus being programmed in leaner non-scripting language
like Nautilus.  Nonetheless - it's a hog for a really nice utility.

Version-Release number of selected component (if applicable):
$ rpm -qf `which rhn-applet-gui`
rhn-applet-2.0.0-28

How reproducible:
Always

Steps to Reproduce:
1. Ensure that you've opted to have RHN's little update applet loaded in your panel.
2. Check top and search for "rhn-applet-gui"

	

Actual Results:  Lots of memory consumed.

Expected Results:  Not so much memory consumed.

Additional info:

Comment 1 Dennis Grant 2002-12-24 13:53:24 UTC
<AOL>

Me too.

Been chasing memory leaks on my system. Found and fixed one in the gweather
applet, now the rhn applet appears next in line:

ps -e -o size,args --sort size (truncated)

11404 gnome-panel --sm-client-id default2
15340 /usr/bin/python /usr/bin/rhn-applet-gui --sm-client-id default5
15972 nautilus --no-default-window --sm-client-id default3
30828 /usr/local/netscape/netscape-bin
284072 /usr/X11R6/bin/X :0 -auth /var/gdm/:0.Xauth

DG

Comment 2 Daniel Veillard 2003-04-08 09:32:10 UTC

*** This bug has been marked as a duplicate of 69467 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:06 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.