Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77450 - PHP does not update Apache's configs
Summary: PHP does not update Apache's configs
Keywords:
Status: CLOSED DUPLICATE of bug 73513
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-07 08:38 UTC by Need Real Name
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-07 09:44:41 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-11-07 08:38:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Installing PHP packages does not change Apache config, so it is impossible to
use php scripts. I have to put all necessary configuration directives for PHP
into Apache config manualy!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RH 8.0 with apache and php
2.Try to access any php script
3.Be suprized - it does not work
	

Actual Results:  It is impossible to use php scripts after installing RH 8.0

Expected Results:  PHP package script should add all necessary directives to
apache config file. I should not do it by hand! It is a very serious BUG!

Additional info:

Should be fixed IMMEDIATELY!!!

Comment 1 Joe Orton 2002-11-07 09:04:51 UTC
The Apache configuration directives for PHP are placed in
/etc/httpd/conf.d/php.conf, which is loaded by Apache by default.
What config directives did you need to add to httpd.conf?

There are a number of reasons why PHP scripts which worked with 7.x
may not work with the 8.0 PHP packages; mostly these are documented in
the migration guide at /usr/share/doc/httpd-2.0.40/migration.html,
which I suggest you read.

One issue not mentioned is that the "short_open_tag" config option is
turned off by default in /etc/php.ini, so PHP scripts which use the
"<? ... ?>" syntex will not work.  This can be changed in
/etc/php.ini.


Comment 2 Need Real Name 2002-11-07 09:44:35 UTC
Thanks for fast reaction. Probably I was not right - php is active and a reason
in this short_open_tag. I've used as test php stuff scripts from RH's standard
"wordtrans" package. It just shows me the php sources :-)
So probably it is a bug in "wordtrans" package, not in php.

So this report should be renamed to "wordtrans php scripts bug".

But IMHO it was extremly BAD idea to set short_open_tag to off by default. To my
mind you should change it, otherwise you will have a lot of complains about php
not working. 

So, even if packages that a part of 8.0 distribution affected by this setting,
it is really better to change this default.

Sorry for wrong report :-) I have not enough time to check all the things. My
idea was that at least packages that are part of distribution should work :-).


Comment 3 Joe Orton 2002-11-07 09:53:03 UTC

*** This bug has been marked as a duplicate of 73513 ***


Note You need to log in before you can comment on or make changes to this bug.