Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77437 - LANG=en_US.UTF-8 crashes Calamaris Squid log analyzer
Summary: LANG=en_US.UTF-8 crashes Calamaris Squid log analyzer
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl
Version: 8.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Warren Togami
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-06 23:56 UTC by Keith Stevens
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-28 07:14:58 UTC


Attachments (Terms of Use)

Description Keith Stevens 2002-11-06 23:56:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 
1.0.3705)

Description of problem:
LANG=en_US.UTF-8 crashes Calamaris Squid log analyzer
setting it to 'C' fixes the problem 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. cat /var/log/squid/access.log | /usr/local/bin/calamaris
2. LANG=C
3. cat /var/log/squid/access.log | /usr/local/bin/calamaris
(assuming squids default access.log and you put calamaris in /usr/local/bin)	

Actual Results:  1. cat /var/log/squid/access.log | /usr/local/bin/calamaris
Split loop at (eval1) line 21, <> line 1.
2. LANG=C
3. cat /var/log/squid/access.log | /usr/local/bin/calamaris
IT WORKED!!

Additional info:

Comment 1 Tim Waugh 2002-11-07 09:13:40 UTC
Not a bash problem, but a calamaris problem.

Comment 2 Tim Waugh 2002-11-10 18:33:19 UTC
Upstream author claims this is a perl bug.  Please contact Cord Beermann
<cord@Wunder-Nett.org> for the test case.

Comment 3 Keith Stevens 2002-11-11 13:24:03 UTC
Something else I found thats weird. (and might be a clue)
While this does this:
[root@localhost root]# cat /var/log/squid/access.log | /usr/sbin/calamaris
Split loop at (eval 1) line 21, <> line 1.

This (in /etc/cron.daily/rotatesquidlogs.cron) works fine:
#!/bin/bash
rm -f /var/log/squid/*.0 >/dev/null
cat /var/log/squid/access.log | /usr/sbin/calamaris -am | sendmail 
keith@acsinc.net
/usr/sbin/squid -k rotate


Comment 4 Chip Turner 2002-12-15 23:20:11 UTC
can you provide actual test data and scripts?

also try perl-5.8.0-70 from Rawhide (should be there soon), as it should fix
most/all utf8 issues

Comment 5 Warren Togami 2005-05-28 07:14:58 UTC
Closing due to lack of activity and likely fixed in modern perl.  If this is
still an issue in RHEL4, FC3 or FC4 please open a new bug with new test
information and exact versions of packages.


Note You need to log in before you can comment on or make changes to this bug.