Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77433 - rpm --excludepath doesn't work
Summary: rpm --excludepath doesn't work
Keywords:
Status: CLOSED DUPLICATE of bug 75550
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-06 23:07 UTC by jmccann
Modified: 2015-01-14 23:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-06 23:08:02 UTC


Attachments (Terms of Use)

Description jmccann 2002-11-06 23:07:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021031

Description of problem:
rpm version 4.1 doesn't seem to recognize the excludepath option.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -Uvh --excludepath /usr/local --noscripts 
/.auto/kickstart/Packages/realplayer/rp8_linux20_libc6_i386_cs2.rpm

	

Actual Results:  rpm -Uvh --excludepath /usr/local --noscripts 
/.auto/kickstart/Packages/realplayer/rp8_linux20_libc6_i386_cs2.rpm
Preparing...                ########################################### [100%]
   1:RealPlayer             ########################################### [100%]
error: unpacking of archive failed on file
/usr/local/lib/netscape/mailcap;3dc99fee: cpio: open failed - Permission denied


Expected Results:  All files that begin with /usr/local should be excluded from
the install.

Additional info:

% rpm -q rpm
rpm-4.1-1.06

Comment 1 Jeff Johnson 2002-11-16 20:10:41 UTC

*** This bug has been marked as a duplicate of 75550 ***

Comment 2 Andreas RAINER 2003-05-05 15:45:23 UTC
I don't understand why this bug has been marked as duplicate of 75550 whereby
this bug (--relocate option problem) seems to has nothing to do with it.
I've not so much experience in using this tool, so I will leave this bug as 
closed and hope to get an answer on how to find the corresponding information.


Note You need to log in before you can comment on or make changes to this bug.