Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 77406 - -DUCD_COMPATIBLE broken in 5.0.6
Summary: -DUCD_COMPATIBLE broken in 5.0.6
Keywords:
Status: CLOSED DUPLICATE of bug 77405
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: net-snmp
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-06 16:59 UTC by Joe Orton
Modified: 2015-03-05 01:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-06 16:59:39 UTC


Attachments (Terms of Use)

Description Joe Orton 2002-11-06 16:59:32 UTC
The compatibility API in 5.0.6 appears to be broken when including
ucd-snmp/snmp_impl.h: I get errors during the PHP build now like:

In file included from /usr/include/net-snmp/library/snmp_impl.h:39,
                 from /usr/include/ucd-snmp/snmp_impl.h:3,
                 from /usr/src/build/164000-i386/BUILD/php-4.2.2/ext/snmp/snmp.c:65:
/usr/include/net-snmp/types.h:11:2: #error "Please include
<net-snmp/net-snmp-config.h> before this file"

(with -DUCD_COMPATIBLE passed to the compiler)

This didn't happen in version 5.0.1.

Comment 1 Joe Orton 2002-11-06 17:02:09 UTC
Double-click alert!

*** This bug has been marked as a duplicate of 77405 ***


Note You need to log in before you can comment on or make changes to this bug.